Trying to Update my firmware but its not LVFS supported

Hi, I noticed lots of errors coming up on my screen and I checked at dell and there is a new bios update available. And two other ones. Now being a noob I am reading in this article how to do it

but I am not on the LVFS list since my laptop is a xps13 7390 2in1. There is a new bios update on dell and two more and I have several drivers that need to be updated. Nothing shows up in my software center and I am not sure how to proceed.
Any help is much appreciated.

Is it because of 2in1?
https://fwupd.org/lvfs/devices/com.dell.ueficbe49cca.firmware

Yes there are some updates available for 2in1's and I just dont want to make a mistake and do more harm than good to my laptop.

With Zorin, you can boot a LiveUSB trial version.
You can do the same with Windows:

If you have access to specific drivers and you want peace of mind; you can boot a LiveUSB of Windows and run the .exe installations that way. Once completed, shut down, remove the USB and boot into Zorin OS.

You cannot update BIOS through WINE.

Ahh ok. So I am basically going back to a windows laptop on a ubs stick and update everything from there. Once done I boot back into zorin and it is automatically transferred over?

BIOS firmware is independent of the User Operating System. It is the Operating system of the Motherboard.

Hey how are you?

I am trying to do a windows live usb using haslo wintousb but I just get error messages. The program doesnt seem to be working. Then I get an option that says save log file as but my usb stick doesnt show. I have formatted the usb stick using disks.

I have never used that product so I am not very familiar with it. Can you relay what error messages you are getting?
In the meantime, here is a Generalized Guide:

I tried the alternative and that doesn't work either. The programs don't seem to work correctly on my laptop. I even started with a fresh zorin and wiped my laptop clean because it started to get stuck and freeze on some programs. I purged wine and reinstalled it thinking it may have been corrupted but no luck so far. Here are some images of the errors that I am getting with hasleo.


Are you plugging the USB stick into a 3.0 port? Try a 2.0 port.

This is me trying to just open the program. No usb at that stage. I downloaded the program from the website and opened it and that is what it looks like.
Also I only have two usb ports on my dell xps 13 2in1 7390

Let's try this guide, instead, then:
https://www.dell.com/support/kbdoc/en-us/000131486/update-the-dell-bios-in-a-linux-or-ubuntu-environment

Perfect it worked like a charm. Do you think I can update the drivers this way too since I still have the line going through my screen in video?

Drivers must run through the Linux system, so, sadly, no. You cannot use Windows OS drivers for your hardware on Linux.
It cannot be done through Wine, either. Wine is a compatibility layer for apps to run on Linux, not for drivers running within it.
I do recall your other thread on this issue - that had me stumped...
And it may well have a simple answer that we have not found yet.