Turn on bluetooth after startup to connect with bluetooth mouse


Can anyone explain how I can turn on the bluetooth automatically when I startup my computer? In the /etc/bluetooth/main.conf file AutoEnable is set te true, but nothing happens when my poweron my laptop.

Have you run:

sudo systemctl enable bluetooth

Does the mouse need to be in pairing mode? Also what make and model of mouse?


I have done that, yes!

I am using a Logitech MX Anywhere S3. It is working, but every time when I startup my laptop I have to manually enable the bluetooth before I can use it.

Have you amended Aravisian's command to:

sudo systemctl enable bluetooth.service


When I run sudo systemctl status bluetooth.service I can see it is active. But in the attached screenshot there are some errors.

Check out the solutions on this closed stackoverflow thread:

I have unblock the bluetooth trough rfkill, but it is still not working. See the attached picture where there are still some errors

Wondering if this might help?

If it does solve the issue here is a solution in respect of configuring the mouse.

The mouse is not the problem, it works fine. The problem is that I would like to have my bluetooth turned on when I bootup my laptop. Now I have to turn bluetooth manually on and then it connects directly. So there are no problems with connecting my mouse.

Have logs shown any errors?

journalctl -xe | grep -i bluetooth

Are the modules loaded?

lsmod | grep bluetooth

Yeah, there are some errors as far as I can tell. See the picture below

Your above errors combined with:

led to a security patch that was introduced back in the 5.8 or 5.9 kernel being at fault for this behavior:

The solution appears to be to disable Link Layer Privacy.
The only directed means to do this that I have currently found is to use patch command to patch the Linux kernel.

So, what I would first try is using a different kernel from default and testing them, first. The Liqourix or the TuxInvader kernels, for example.

Are you on Zorin OS 16 or Zorin OS 17?

Sounds like a really complicated fix... I am on Zorin OS 16.3

Patching can be complicated. Can you instead try a different kernel by following the terminal commands in this post, except you will be testing bluetooth instead of sound:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.