Turning off animations results in lagging mouse

I did it. I don't know how. But I turned on animations. It's not something I would normally do. Now I have a little square chasing my mouse cursor everywhere.

If I turn animations off, the mouse action on screen becomes nearly unusable. I've tried rolling back my install by a day from a timeshift backup but this square keeps following my cursor.

Please help me before I descend into madness. :wink:

Hi and welcome to the forum :slight_smile:
Could you please tell us the version and edition of Zorin you are using?
GNOME desktop and XFCE desktop behave very differently.

1 Like

When you turned on animations I guess you did not expect a Tom & Jerry cat and mouse chase to appear on your screen.

Please reply to @FrenchPress question whether you have ZorinOS 16 Core, Pro or maybe ZorinOS 15.3 Lite. We need to know if your desktop is GNOME or XFCE.

EDIT: Also, Is your mouse wired or wireless?
Have you tried disconnecting and reconnecting it?

2 Likes

That is close to what I expected when I turned it on for the first time. :rofl:

I have the pro version. The mouse is wired. I have tried unplugging it and then plugging it back in. I'm running on an AMD Ryzen 3750 based machine with 16GB memory.

I have enabled 200 percent scaling on my 4k monitor. I also tried altering the font sizes. I set them all back to what the system defaults were but the problem persists.

I tried connecting a Bluetooth mouse. The problem seemed to momentarily go away. Then it came back. If I turn off animations, both mice track in a very chunky mode and are practically useless.

I'm at the stage where I can just go back and rebuild the system. I do have a backup. I just wanted to see if there was an easy solution. I also really want to participate in some small way.

I'm really liking this OS and GUI. I sacrificed Windows on a brand new machine to run it. Even with this little snafu, I'm not missing the Windows. :wink:

Thanks!

1 Like

Aha! The trailing squares went away and I don't recall doing anything to specifically address the problem. I did install remote viewer, the X11 vnc server, and Steam. However, the problem of turning off animations still results in a chunky performing mouse. So I'll leave them on.

1 Like

Okay. I spoke too soon. It's back.

1 Like

What if you turn the 200% scaling off?

1 Like

Nope. Turning off scaling doesn't work. The problem follows.

If you guys don't need any diagnostics from me, I'm reverting to my original install and go from there. I'll wait for a couple hours for your reply.

Zorin 16 Pro includes the installation assistance.

If none of our suggestion works, you could also ask for a help directly to the Zorin team by sending email you have received when you purchased Zorin 16 Pro.

2 Likes

I did try a websearch for this in relation to Ubuntu 20.04, but nothing similar came up.

I assume you still have your Zorin16 Pro USB?
Can you boot that and see what happens when you turn mouse anmations on/of in "Try Zorin" mode from the USB?

2 Likes

Though old, perhaps this thread may still be useful:

I had never heard of this, either.

2 Likes

Thanks for this. This page has several things to look for if the problem raises its head again. I started over early this morning from a cold install. The problem is gone for the moment. By default, animations are turned on so I haven't dared turn them off. I shall be aware of things like zoom or an app that does this. What surprises me is that I kept creeping backwards through several snapshots I normally take with Timeshift. I couldn't shake it even with the snapshot I made right after the original install. Definitely some weird stuff going on.

3 Likes