Two bug-related items (Zorin OS 17 Pro)

Thank you to everyone. I will try changing the driver later and report back.

Oh - one question - do AMD video cards fare any better under Zorin? I may get an AMD card at some point eventually. The 1060 is an older card.

Well - gonna change the driver via Zorin's built-in tool. Wish me luck.

Very interesting. Entered the "NVIDIA-SMI" command in the terminal, and got the following message: "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running." (This is after I attempted to change the driver to version 470.) What happened? Sighs ...

WARNING: you should run this program as super-user.
*-display UNCLAIMED
description: VGA compatible controller
product: GP106 [GeForce GTX 1060 3GB]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list
configuration: latency=0
resources: memory:a2000000-a2ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:c0000-dffff
*-graphics
product: EFI VGA
physical id: 2
logical name: /dev/fb0
capabilities: fb
configuration: depth=32 resolution=1024,768
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

OK. I saw this: "llvmpipe (LLVM 15.0.7, 256 bits)."

This was listed in my settings information.

I looked up "llvmpipe" online and found this.

Link: Fixing llvmpipe Issue with NVIDIA Graphics on Ubuntu 20.04 LTS | DeviceTests

Can I avoid having to do all this by somehow going through Zorin's own built-in tool instead of having to use the terminal? Why isn't Zorin's own tool working? This is unfortunate ...

The terminal is your friend. I moved from WIndows OS to GnuLinux via Zorin OS not very long ago. Now, I use the terminal for most system tasks including all installs and removals.
The guide you linked to gives step-by-step instructions, so even using the terminal without familiarity is safe and easy to follow.

Do you have Secure Boot disabled in BIOS Settings?

Hi, @Aravisian - yep. When I’m at my PC, I’ll take a couple pictures of the BIOS and show you them here. I’ll also give it a shot with the guide. Thanks.

Update:

I followed the guide. When I got to "sudo prime-select nvidia," I inexplicably got a message saying that the integrated GPU wasn't found. Everything else shows that the drivers are present, etc. I am fed up with this. And I don't have pictures right now, but I can assure you that Secure Boot is off (@Aravisian). I'm taking a break from this. Also, I've ordered an AMD video card that should arrive tomorrow. I've had it up to here with NVIDIA. Even when I was on Windows, I had issues with NVIDIA (nothing like this, though). I'd been meaning to switch back to AMD, and this ordeal has pushed me to make the change. Hope the new video card will resolve all my issues. In the meantime, anyone who's got insight into the "integrated GPU" thing is welcome to chime in. I just don't get it ...

Many motherboards come with an Intel GPU built into the motherboard - that is Integrated Graphics.
Using a Graphics card like Nvidia or AMD is Dedicated Graphics.
Not all motherboards have an integrated Intel graphics chip.

Hi, @Aravisian - thanks. I know what integrated GPUs are. What I was referring to was how I don't understand they'd come up like this, especially when Zorin was working with my NVIDIA card only to stop working with it when I tried to switch drivers to see if I could get the graphic artifact (around the software center's window) to disappear. So it was more of a "why" question than a "what" one. In any case, the AMD card (RX 580) is on track to arrive today. If necessary, I'll reinstall Zorin OS, but hopefully the OS will automatically detect the new card, and set things right after that. Last thing I'll say is that I hope the Zorin brothers see this thread, and investigate their own built-in driver tool. They should be able to account for stuff like this happening when using Zorin OS' built-in tools, and make it so that this "llvmpipe" stuff gets dealt with internally without any visibility to the end user (e.g., the OS handles any and all foreseeable discrepancies, and executes user actions within the OS). Just saying, you know? In any case, I'll install the new card later, and report back here with the outcome. Thanks again.

The Zorin Built in tool can list and install the Drivers, but Nvidia drivers are proprietary, which the Built In tool notes:


llvmpipe is a fallback to ensure that you can administratively function even if the graphics fail; without which, you would have no GUI screen to display or interact with to try to troubleshoot your issue.
Having these visible to the end user is encouraging, because it means that the end user is in control of and able to take charge of their own machine which is their property. You can easily imagine the nefariousness and taking advantage of that can occur when the end user is not informed or able to directly control their owned machine. Indeed, many of us moved to GnuLinux for this very reason.

The AMD drivers are included within the Linux kernel, so in this regard are different from Nvidia which must be independently supplied.
Booting up with an AMDGPU should work - but if you run into any trouble, please post here to see if we can help.

I must point out that this would be a security issue, as well. If user actions can be executed without visibility to the user, that opens up a hefty can of worms of exploits...

1 Like

Didn’t know that about the AMD GPU driver and the Linux kernel. That does help to know. Thank you for your kindness. @Aravisian (And yes, I’ll report back - not a problem.)

Interesting. I was just reading about the AMD GPU driver. Why hasn’t NVIDIA done it this way? AMD’s approach sounds wonderful. Makes complete sense, too. Link: AMDgpu (Linux kernel module) - Wikipedia

I believe because AMD is a stakeholder in Linux whereas Nvidia is a proprietary developer.

1 Like

If Wayland should replace X11, then AMD will fare better than nVidia cards.
The downside to Wayland - Windows don't run natively in Wayland - needs Wayland 'X' :rofl:
On a downside to Wayland, no Accessibility options will run, so users dependent upon screenreaders would end up being forced back to Windows and Proprietary software such as JAWS at £650 per licence! True NVDA is a good alternative, but lets remember that GNU/Linux is free, as are all the applications. If you purchase any Computer, you have paid for Windows in the price (about 30% from memory is added to the price of a piece of computer equipment which is paid to Microsoft).

1 Like

Update:

Installed the RX 580 card. Zorin came back to life.

Everything was automatic. All is well. Games work well.

No screen artifacts. Tossed out the NVIDIA card. Bye-bye.

Guess everyone can mark this entire ordeal as being resolved.

Thanks to everyone who replied, of course. Have a good one.

1 Like

Am tagging @staff here so the Zorin brothers are aware of the problem I encountered with the Cheese app. The Zorin APT of Cheese didn't work, but the Flatpak version of Cheese works perfectly. Might want to fix this in version 17.1 by replacing the Zorin APT with the Flatpak version of Cheese. That's all. Thanks.

1 Like

I confirm that I have something similar. With the default installed version of Cheese on Zorin OS 17 Core:

  • When you open the app, there is a strange "loop" of the first 1 second of whatever Cheese "sees" via your camera. Dropping the camera resolution to 640*480 works around the problem...but you are in a lower resolution, which is not ideal.

  • I didn't try taking a picture or video clip to see if it worked.

  • I removed Cheese via Software, then re-installed the Flatpack version (also via Software).

Cheese works like a champ now, and at full resolution.

1 Like