Two bug-related items (Zorin OS 17 Pro)

As the subject header says, I have two bug-related items to share.

They are both in Zorin OS 17 Pro, which I bought recently to support Zorin.

I hope I am doing this correctly. If I am not, please tell me where to report bugs.

First bug:

See attached picture. It's self-explanatory. I am using the included proprietary NVIDIA drivers. When I installed Zorin OS 17 Pro, I chose the option to load the live USB with "modern NVIDIA drivers," and installed Zorin from the live desktop. This strange screen artifact seems to happen only with the software store. Also, when I tested Zorin OS 16.3 Core (live), this did not happen. Maybe this is a bug that Zorin needs to investigate? I use a NVIDIA GeForce 1060 3 GB card.

Second bug:

It seems like the version of Cheese included in the Zorin OS 17 Pro ISO is buggy. It starts up OK and although I had to adjust the video resolution for my camera to be able to take screenshots and video, it turns out that I kept getting an error and couldn't take pictures or videos. I went on the software store, and downloaded the Cheese flatpak version. That one worked 100% and I was able to use my camera with Zorin OS 17 Pro that way. I uninstalled the APT version that came installed by default with Zorin, and stuck with the Flatpak version, which I am using now. Works great. Zorin may want to investigate further, or just simply replace the APT version with the Flatpak version on its ISO for Zorin OS 17 Pro.

I believe that's it. Hopefully there will be more bugfixes in version 17.1. (Or Zorin will decide to release a bugfix update via the software store or the updater; that'd be great.) Also, if someone from Zorin can confirm that they saw my post, and will take note of the bugs reported, that'd be appreciated. Thanks.

1 Like

Reporting bugs can be done in the Feedback subforum; However, before we opt to move your thread to that subforum , would you like to try troubleshooting these issues?

I am stepping away from the computer for a while, but if you would like to troubleshoot, you can relay the Nvidia Driver you are using (assuming you are on the base kernel. If not, also include which kernel you are using).

Can you relay the error that Cheese presented?

Hi, Aravisian:

Surely. See below, please ...

Re: NVIDIA driver - see below screenshot ...


Re: Cheese, all I see is: "There was an error playing video from the webcam."

(Not helpful - but again, I've switched to the Flatpak version - works great.)

All and any advice or guidance you have would be most appreciated. Thanks.

Just curious, what happens if you use the Nouveau drivers instead of the Proprietary nVidia drivers (which I personally tend to avoid, perhaps because I am not an avid PC Gamer - its PS4 Pro all the time for me these days!)

OK. I've got quite an update here. I'm actually using the "Noveau" drivers. What happened was that I tried to switch to another NVIDIA driver using System Settings (to an earlier version). What happened was that my computer wouldn't boot correctly. See pictures below. Not sure what happened.


It was not until I got back into my account using recovery mode that I was able to switch over to the "Noveau" driver and resume normal boot function. I tried switching to another NVIDIA driver, and I got the same result as what you see in the pictures above. I went back to the "Noveau" driver, and once again I have normal boot function. Any idea on what's causing this, and how can I fix it? I'm loath at the idea of reinstalling Zorin, even though this is a fresh install with relatively little work gone into customizing it.

Frustrating ...

One more thing - the picture of the blinking cursor is just that - it leads to nothing. I kept waiting and waiting until I gave up and tried to restore access through the recovery menu. Thank goodness I was able to switch the drivers to the Noveau drivers, but now I don't have 3D acceleration for my games, etc. Help. Thanks!

OK, see if this guide helps:

With all due respect, I’d rather try to fix this through the same tools Zorin provided for the same purpose. If the NVIDIA drivers can be switched thru the systems setting app and is meant to be that way by design, then I’d rather have that work right instead of potentially worsening the problem by following this guide. See my point? But thanks, though … I mean, Zorin’s built-in tools should work. So let’s try and handle this problem that route.

1 Like

Using (as you already demonstrated via your previous screenshot); Software & Updates > Other Software, you can switch Nvidia drivers.
If this means is not working, something may be interferring.

Do you have Secure Boot enabled in your BIOS Settings?

Are you Dual Booting with Windows OS?

I believe Secure Boot is off. I would have to double check later. And no, I’m not doing a dual boot setup. It’s just Zorin. I’m a bit disappointed. This all shouldn’t be happening, especially when using in-system tools meant to streamline the process.

Please do check as that is a primary culprit.

This is a perfectly normal feeling that we all get on anything that doesn't work as expected. This is why humans are problem solvers and solution finders.

1 Like


Secure boot was disabled, but I went ahead and switched my settings from UEFI to Legacy in the BIOS. That did help. I was able to boot back into Zorin. However, after I'd switch NVIDIA drivers using different driver versions, Zorin wouldn't pick up my correct hardware information (e.g., monitor), and wouldn't offer me any higher resolutions to choose from, etc. System Settings was showing that I was on different NVIDIA drivers (good), but Zorin wasn't showing me resolution options to choose from (bad). So what I ended up doing was reinstalling Zorin. Frustrating. Now I'm back to square one, as they say. The weird thing was that (before reinstalling Zorin) even when I went back to the original NVIDIA driver (same one that came installed, and was marked as "tested" by Zorin), my hardware wouldn't be detected (e.g., monitor). Now that I'm on a fresh reinstall (using the SAME drivers), Zorin is able to detect everything correctly. Why did I have to reinstall Zorin just to have that happen?

What now? Thanks ...

Yes. See my latest update. Thanks.


I do not use NVIDIA but (if I recall correctly) those marked "tested" (I don't think by Zorin BTW) are best avoided.
Try a 525 driver, as others have had issues with the 535.

To be honest, I am "afraid" to try anything again with the drivers. I'm hoping to hear back from @Aravisian or someone else more experienced with Zorin to provide further counsel as to what to do next. Right now, Secure Boot is off, and I recently disabled the "legacy" options (previously they were set to UEFI before I set them to "legacy," and now they're completely disabled). Right now, I'm going to sit tight until I hear something from someone about potential next steps. I don't want to have to reinstall Zorin again. EDIT: If it helps, my motherboard is a Gigabyte B360M-DS3H.

Also - I did try switching to the 525 driver. Zorin wouldn't pick up on my monitor, nor would it offer me any additional resolutions. Nothing was happening, so that's why I went ahead and reinstalled Zorin. Now everything is working. I feel like this is a bug within Zorin that may have slipped by. I don't know ...

There is only one Open Source Nvidia driver: Nouveau.

The rest will show as server, proprietary or tested.
This is where things get complex.

  • All of them are proprietary.
  • The Server edition is identical to the rest. the only difference is that the server edition has longer support for security patching.
  • The 470 (proprietary, tested) driver turned out buggier than the 470 (proprietary). The tested notation is supposed to mean that the driver was tested for performance and stability.

With the first point: All are proprietary. This means that they are locked from any code review or modification by either us or the ZorinGroup. It is like a sealed box that we are not permitted to open.
These are created by, supplied by and maintained by Nvidia and if there happen to be bugs; it is due to Nvidia. ...And... Nvidia has a very long reputation of pushing out products with bugginess in their drivers. On all OS's. Sadly, for us, the users, on Windows O.S. or GnuLinux, the best we can do is try changing drivers or kernels.

To your situation:

The Nvidia 1060 is an older card. Really, it should work on the newer drivers. It should. I would try the 460 or 470 drivers, just in case...
But particular to it, the usual necessary trick to get it to behave properly is to install the drivers at the point of O.S. installation.
Which puts you in a place that you did not want to be: re-installation of Zorin OS.

Thanks. I’m not against changing drivers using Zorin’s built-in tool, and seeing what works best. I’m just concerned about Zorin not detecting my video card and monitor properly after I change the driver. I will try again, now that I know Secure Boot is off and the “legacy” and UEFI options are OFF. I’m almost “scared” to try. Ha. What do you think? @Aravisian

I understand that fear but it is a freshly installed system. I would view it as a test bed and playground for now and be bold and fearless.
Once you repeat an action a few times, it builds confidence and strength.



I am currently testing the 545 driver on Zorin OS 16.3.

1 Like