Two-finger touchpad scrolling is inverted in Zorin Lite

Hey everyone.
After installing Zorin Lite I realized the two-finger touchpad scrolling is inverted, which means moving my fingers down scrolls down. This is the opposite as to what happens in Zorin Core or Windows 10. How do I get it back to normal?

You should be able to set things properly by opening Settings from the app menu, then navigate to the "Mouse and Touchpad" option.
In that window, ensure that Scroll Direction is set to your liking.
You may see the option as
Reverse scroll direction preceded by a checkbox.

1 Like

Oh. I didn't even bother trying that, because it was on the buttons tab, not the touchpad one. Thanks.

Uh.. it fixed the issue on Firefox, but the actual Settings app is still inverted for some reason.

Maybe log out and back in, then test - I am not sure if it just needs the desktop refreshed after changing the setting.

Didn't work. I tried restarting too. Only browsers seem to have been fixed. The files explorer, task manager, and settings app all still scroll down if I move my fingers down.

Found this old bug report:

https://bugzilla.xfce.org/show_bug.cgi?id=12575

I read all the replies and the original bug too, but my Linux knowledge isn't enough for me to attempt anything. What do I do? A lot of replies in the original bug said they had fixed it. But some mentioned Gnome. Isn't that the thing Zorin Core runs on? This is Zorin Lite.

The link I posted was for xfce, clearly named in the url.

11193 – GTK3 apps don't understand natural scrolling
11193 – GTK3 apps don't understand natural scrolling
11193 – GTK3 apps don't understand natural scrolling

Which of these do I try?

You can try:

sudo apt remove xserver-xorg-input-synaptics && sudo reboot

And if that does not work, try the other suggestion:

sudo nano /usr/share/X11/xorg.conf.d/40-libinput.conf

Ensure the line for mouse, pointer or touchpad is (Or change it to):

Option "NaturalScrolling" "true"
1 Like

First line fixed it.
Thank you!

1 Like