UI Scale Issue

Hi Everyone!

I'm happy to say that I've been using Zorin OS 16 for approximately a year now. When my 2017 Macbook i5 died in mid-late 2022 I decided to move to a desktop PC as it would make gaming far easier. Happy to say that I've had pretty much no issues aside from those that come with learning a new OS. Really happy with how Zorin OS provides the sleekness that I loved about MacOS but with much of the functionality that Windows provides.

However... I was recently doing a presentation and while I was zooming out of a webpage (ctrl -) and my entire UI zoomed out and has become difficult to use. Text is extremely tiny and so is everything else. I've tried both Wayland and X11 to no avail. Fractional scaling hasn't helped since it has made running games very difficult and weird glitches appear during normal use (sometimes everything is clear and sometimes it is very blurry).

I run two monitors. I have no luck using them both together nor when I use them separately and
I want to know how I can fix this issue (both are 1080p - one is 27inches and the other 24inches). I really don't want to have to start using Windows for work and gaming again. I thought after restarting this issue would be resolved but it has not (two weeks as of now).

Would appreciate any advice I can get on how I can fix this!


Have you tried ctrl (+) to zoom out again if you used ctrl(-) to get into that state?

1 Like

Yes of course, I've reset the zoom, here's an example. The UI for all my apps have become smaller (the tool bars especially). Increasing text size in Zorin Appearance doesn't help either.

What is your current screen resolution?

xdpyinfo | grep 'dimensions:'

1920x2160 pixels (508x571 millimeters) when I use both monitors, both are 1080p.

1920x1080 pixels (508x285 millimeters) for each monitor respectively.

Is that the same resolution it was set to before the screen changed size of appearance?

Yes, I always had them set at 1920x1080p in Display Settings.

This is a strange one. Ctrl+ should only zoom in and out of a webpage.

The Super key is the Windows Key on PC's:

  • Super+Alt+8: Toggle zoom enabled/disabled
  • Super+Alt++/-: To increase/decrease zoom.

The first one makes everything zoom in like crazy.

The second one didn't do anything as far I am able to see.

I'd be alright with the issue and only having to increase text size but it doesn't increase it on the task bar (date) and the Zorin Menu is smaller and doesn't fit everything in it like it should.

It should only enable or disable the ability to use the second shortcut - it should not create a zoomn effect itself.

win+alt+ (the Plus key) did nothing? You profile says you are on Core Not Lite. Is that correct? (Your screenshot does look like Core Desktop, but I best check...)

Ok let's try a gui method.
Please install Gnome Tweak Tool:

sudo apt install gnome-tweaks

Navigate to Keyboard & Mouse > Additional Layout Options.
Look for the Zoom section and expand it.
Look at the options for the Zoom in increments section.

Win+alt+plus didn't do anything, I am using Core

I couldn't find zoom in any of these.

Did the Tweaks app change? Ok try this:

Okay.. I was going around the tweaks app and I found this. It was set to .75 and setting it to 1 fixed everything!!!

Zorin menu fits and everything is exactly as it was before, yes!!!!!


I would not have guessed Fonts - since you said that titlebars and the panel were zoomed out but... I am happy with a solution.

Thank you so much for your help!!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.