UI scaling in Sublime text

Using Sublime Text on my high dpi monitor the UI elements are too small
As it uses it's own GUI framework [I think] the only way to change scaling is via
ui_scale in user preferences, changing which has absolutely no effect on my system
Any advise in how can I change the UI scale is much appreciated
I know this is more of a sublime text Issue, but browsing through sublime text help forums ,there is no case of ui_scale not working, so I wonder is it's a issue
due to Zorin overriding
I tried changing font scaling from tweaks in Zorin which too had no effect
I would rather not use fractal scaling

Try installing Gnome Tweaks; under "Fonts" change the "Scaling Factor" a bit to see if this helps.

Also, question of the year: how did you install Sublime Text? If it's a flatpak that may explain why the fonts are not being scaled appropriately for this one program (I assume everything else looks normal?)

If that's the case I'd suggest installing Sublime Text as a native .deb format. You can find instructions on how to do this in their website:


1 Like

Under Preferences > Sublime Settings, can you try adding
"ui_scale": 2
"ui_scale": 1
and reboot and test?

It seems I have asked a terribly unclear question.
I'll clarify below

This I already tried

That's the way I installed it. Not a big fan of snaps and flats.

I also tried this (actually tried it first) which too had no effect.
Thats the reason for me asking here, as Sublime text uses its own GUI framework I dont know how (if at all possible) I can change the scaling from outside sublime? As the native way doesn't work

Sorry, I read (or rather, didn't) too fast.

I'm afraid I don't really know what else to try. I don't have a high dpi monitor, so never run into type type of issues myself and wouldn't know where to start looking for answers if I did.

Have you tried switching between X11 and Wayland to see if it's related? It may also be something regarding Gnome itself, although I've found some (old) threads over on ST forums and GitHub where people complained about similar issues while using different distributions and desktop managers.

I don't really understand what "

merge up means"

An excellent suggestion! I'll see what happens..

I seem to have discovered another case of [thing not working for no reason : now works mysteriously]

I have no idea what fixed it :confused:

1 Like

You must be a :mage:, so we may call on your help with illogical sound issues.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.