UI scroll bar width

7> UI scroll bar width

I noticed scroll bars in modern operating systems getting more and more sidelined. They are getting narrower and therefore harder to click on. Win10 made it even worse, since it hid them in some cases, and I had to hover or click just to get to it. Silly design choices at the expense of usability, which is how I often thought of Windows.

I noticed Zorin also has this (though to a lesser degree). I notice it in LibreOffice and Firefox, where I do most scrolling. The scroll bars are thin; the bit you click on even thinner. The mouse scrollwheel is fine for a small scroll, but not when something is multiple pages long and a click and drag would be more efficient. I tried a plugin in Firefox but it didn’t help. As such, I assume the scrollbar width is a universal OS UI choice. Zorin seems customisable in many ways – is there some setting I missed where I can make the scroll bar wider, like I used to have? Or some hack to do it, a profiles.ini or something? I’m surprised it didn’t seem to be anywhere in Settings or Zorin Appearance, the two most likely places. [As an aside, why isn’t Zorin Appearance part of Settings? Ditto Taskbar Settings. They are all places where we can customise the GUI, so to me it makes sense to have them in a single place, rather than three separate programs. Feature suggestion to help newbies?]

1 Like

Thinner and thinner scrollbars are part of a developer push to get rid of scrollbars entirely. Gnome wants them gone (along with its long list of other removals) and has been whittling away at them. The latest gtk4 removes scrollbar steppers entirely.
They just keep pushing.

In order to restore scrollbar functionality a user must do some custom configuration.

In your Home Directory, you have a folder : .config
If you do not see it, hit the keyboard shortcut ctrl+h to reveal the hidden folders. This shortcut toggles that on and off.
Shorthand, in Linux, for the path to your Home Directory (/home/$USER) is simply: ~
In this case, navigate to ~/.config/gtk-3.0/ and in that directory, create a new Document File named gtk.css

Paste the following into it:

 scrollbar.overlay-indicator:not(.dragging):not(.hovering) slider,
scrollbar.overlay-indicator:not(.dragging):not(.hovering).horizontal slider, scrollbar.overlay-indicator:not(.dragging):not(.hovering) trough {
     min-width: 8px;
     min-height: 8px;
}
 scrollbar trough, scrollbar slider {
     min-width: 16px;
}
 scrollbar.horizontal trough,  scrollbar.horizontal slider {
     min-height: 16px;
}

Save the file.

Log out and in or reboot to test.

3 Likes

It really pays to have a themer on this site, holy cow, what an awesome response. A+ :star2: :star2: :star2: :star2: :star2:

1 Like

Just tried it - no errors, but all the scroll bars are as before. :frowning: I double checked and the file is still there with the correct code. (When you said create a new file, I assume you meant .txt file, but changing the suffix to css instead of txt?)

I really don't understand why people want to deprecate scroll bars. They're a basic tool! Especially for beginners, it's something they can quickly learn and understand, rather than learning various keyboard shortcuts. I'm glad I'm not the only one who gets frustrated by it! :slight_smile:

1 Like

I tested this entirely before submitting my post... by enlarging my scrollbars to rather huge proportions (As that makes it undeniable that it is working.)
Can we retrace your steps?
Yes, the file name would be just like making a .txt file, except it would be .css, instead.
So, it would be named gtk.css and it would be placed in ~/.config/gtk-3.0/ directory.

1 Like

Hi, this is the folder and the file:

But the scroll bar is as before:

Maybe this is related to my File explorer issue that the tip Artyom gave me once to hide folders just doesn't take. It lets me change the ini file, but then it doesn't affect anything. There are a few issues like this, which is why I'm wondering if there's a single issue underlying them all.

When you Hover Over and use the Scrollbar, does it change size?

You may be seeing Overlay-Scrollbar feature... which is something I always disable on my builds.

1 Like

No: if I hover the central bit just goes darker (same if I click drag). It doesn't change size.

I don't know what Overlay-Scrollbar is, I'm afraid!

I can understand some people who dislike scrollbars (even if I don't understand why!) wanting a narrow default, but I don't understand why they wouldn't include a config or setting for the user to set their own preference. One of the reasons I dislike Windows is because it feels like Microsoft govern all the (often awful) choices, and we have to use hacks to override some of them (others we have to put up with). But Linux feels more open, so I'm surprised there isn't a Gnome setting for this.

1 Like

In my opinion, Gnome is a Linux version of Microsoft.

Overlay scrollbars "hide" when not in use. It's actually not a bad feature, just not something I personally want.

If you are looking at the Scrollbars in Firefox browser... They will not use the gtk scrollbars (Your system theme) unless you tell it to.*
Have you tested the scrollbar across a variety of applications?

*We can walk through enabling system theme being used on Firefox later if we get this issue sorted out first.

1 Like

Yes, it's every program. Firefox, Files, email, LibreOffice. The scroll bar is identical in size and appearance in each one. It is always visible, and always thin. The only tweak I have tried is the .css file I added to that hidden folder.

Overlay scrollbars - I think I came across them once, hated it, even worse than thin ones! Again, I don't mind if people like them and use them, because we all have different needs and preferences, but it's the kind of thing any OS should let the user control. :slight_smile: (i.e. we are in agreement.)

Have you logged out and back in? Here is a screenshot on mine, with the size increased dramatically:

Compared to Normal Size:

1 Like

Wow, that's quite a difference!

Yep, yesterday I logged out and in, but it was the same. So I did a full reboot, no change. I turned my PC off at night (fully off - not hibernate - I turn the plugs off at the wall!) so that was another reboot, and I did one more just to be safe. :slight_smile: But my scroll bar is still narrow.

I just double checked - the .css file is still there, and has the same content. It's as if Zorin is ignoring it? I noticed if I make changes to
gedit .config/user-dirs.dirs
the change is also not saved or acted on. May be a red herring, or connected in some way?

No... these work. They work on every desktop I use. Zorin OS is not programmed to ignore user settings.
Can you please open the gtk.css file and change the scrollbar width and height to 24px instead of 16, log out and in, then open an instance of Files (nautilus) with a filled directory to ensure the scrollbar is present and send a screenshot here?

1 Like

Interesting. Here's the new file:

I logged out etc. The first appearance in Files is still narrow:

But when I hover over it, it does go thick now:

But it only seems to do that in Files, and only when I hover over it (not changing its default appearance). It also doesn't change the scroll bar in Thunderbird or Firefox, even when I hover over them.

As I already said; Firefox does not honor the gtk theme and we must tell Firefox to do so.
Thunderbird is also a Mozilla product. It does the same as firefox.
It's annoying... And this partly stems- again- from Gnome. Gnome introduced CSD's, pushing for other developers to take on the mantle of handling the "decorations" like the window borders and interior css.

And some apps may be using the gtk2 portion of the theme, which I can help you with as well.

At this point, we have established that the file is working.

So, let's disable Overlay Scrollbars for you:
In terminal please run:

gsettings set org.gnome.desktop.interface overlay-scrolling false

You may also need to addteh following to your ~/.profile file:

export GTK_OVERLAY_SCROLLING=0

To Fix Firefox
In your browser address bar (in a new tab) type
about:config
There is a search bar - search "scrollbar"
Set widget.gtk.alt-theme.scrollbar to true
Set widget.non-native-theme.gtk.scrollbar.round-thumb false
Set widget.non-native-theme.win.scrollbar.use-system-size false
Set widget.non-native-theme.scrollbar.size to 16
Set widget.non-native-theme.scrollbar.active-always-themed true

Now, optional:
In the top searchbar type theme
Then locate in the results:
widget.content.gtk-theme-override edit this to be the name of the theme you are using as it appears in Zorin Appearance.

In your ~/.config/gtk-3.0/gtk.css file, set the size from 24px to whatever size you like. 16px or 18px...

This should get everything working that uses gtk3.

For gtk2 - I would need to know which exact theme you are using and make and send you the files OR walk you through the process of resizing the image files in the Scrollbar folder.
You can choose which is best for you.

2 Likes

The more I hear, the more frustrating the Gnome developers sound! It seems bizarre for them not to include a simple setting for the UI where a user can choose their own scrollbar width! If I was in charge etc etc ...

Terminal gsettings line = no problem.

~/.profile file = I added that line at the end (if I end to put it somewhere else let me know and I'll move it).

Firefox: I made all those changes to the first five widget settings (apart from the last one which was already true).

"Then locate in the results:
widget.content.gtk-theme-override edit this to be the name of the theme you are using as it appears in Zorin Appearance."

I don't know what the name of the theme is, this is what the tab shows:

So is the theme name "adwaita"?

"In your ~/.config/gtk-3.0/gtk.css file, set the size from 24px to whatever size you like. 16px or 18px..."
Okay, set to 16 for now.

I logged out and in.

Just for info, the Firefox bar seems a pixel or two wider; the LibreOffice bar is more like how I expect a scroll bar to look (both shown for comparison with default Thunderbird):

For gtk2 - I'm not sure which is the best approach. Normally I make a txt file with a set of instructions for things like this. But if it is going to be more complex I wonder if it might break in the future or cause problems, or if doing it once sorts it out forever (until the next install!) When I raised the topic I had hoped there was a single universal setting I could change somewhere with a text command, I didn't realise how sort of messy the UI scrollbar settings are in Gnome! It's weird that the people in charge of it don't seem to want to keep it simple and let the user change universal settings. Is KDE better for things like that, or is it six of one and half a dozen of the other?

Many thanks!

Yep.

That is not right... it should look the same as the rest.
Firefox... sigh...
Back into about:config and search for
widget.non-native-theme.win.scrollbar.use-system-size - false.

widget.gtk.alt-theme.scrollbar_active - true

widget.non-native-theme.enabled - false

No, gtk2 is all settled in and not receiving updates that can cause breakage.

Let the User Change = Control.

Ok, I think your answer is that you prefer I make the adjustments and send you the file. I will try to wrap it in a self-installer for you, so that all you need to do is Double Click it.
It may take me a day or so- and it's a bit trickier as you are using Adwaita which is...
Gnomes default Theme. They went to greater pains to make it harder to change.

1 Like

Only just saw this. Ah - in that case, please don't go to the trouble of creating anything if it is theme specific! I am new to Zorin so may change the theme at some point since I like to try different things out. In fact, I went into the other tab, and now it seems adwaita is no longer selected. So anything based on particular themes, I'm best avoiding.

I made the other Firefox change (one of them - the others were already correct) - yep, that worked! The Firefox scrollbar is now easier to select.

I guess what I have learned is that a) the default scrollbars are too narrow, b) there is no single easy way to change that across the whole GUI, and c) unless Gnome bring that in as an option, the only way to change it is to alter settings and files in quite a few places, and it may only work with certain theme combinations. After considering c), I am more inclined to just put up with it and nag the Gnome people to make it a user GUI setting (since that is the only easy solution, and the one that benefits all users of Zorin and Mint etc, not just me). I did send them a message today, just on the off chance that they listen. In the meantime I'll just leave the settings as they are, so it is wider in some apps.

I really appreciate your help. If there are any non-theme specific changes I still need to make then I could do those, but I don't want you to spend time on anything that could easily be undone by me trying different appearances!

1 Like

Linux Mint has this setting for disabling Scrollbars AND for setting a custom size.
However, just today I learned that in Nemo 5 - the latest Cinnamon Desktop - these features have been removed.
I am dismayed.

2 Likes

Oh no! It's like the world has gone mad. :frowning: