Unable to access smb share under Zorin


I just decided to refresh my desktop PC and installed Zorin OS for the first time to test it out. I otherwise had a Windows 10 install which was making me increasingly uncomfortable.

Anyway, to the topic. I have a Raspberry Pi in my home network running OpenMediaVault which was very smooth and easy to access under Windows. However, no matter what I seem to try, I am unable to connect to it in the file browser under Zorin. Every time I try to open the share, entering the username and password of the OMV user, I get a prompt saying "Unable to access location. Failed to retrieve share list from server: Invalid argument."

Here I am stumped. It works without a fault on Windows, but on Zorin it is a hard no-go it seems. I have attempted to search the internet for a solution, but I am finding nothing that matches my issue here.

I would be very thankful for any and all help!

I do not use Samba, but a search yielded this post with a suggested solution:

My message was "failed to retrieve share list from server: invalid argument", while trying to connect my PC (LM20) with a network router's USB.
Inserting these two lines below 'workgroup = WORKGROUP', on /etc/samba/smb.conf, did the trick:

client min protocol = NT1
server min protocol = NT1

Then restart the service.
Hope that helps

1 Like

I was also just now looking into this as I've been asked recently to setup network sharing so I need to learn this stuff...

As far as I can tell from a quick search there seems to be an issue with Nautilus itself. Some threads suggest using the NT1 protocol but it looks like that's an old protocol, slow and insecure, so proceed with caution. One thread I read mentions that Windows uses this lower version of the protocol only to discover clients and network shares, and then upgrades to make the actual connection. This, apparently, is something not yet available on Nautilus.

With all this in mind there are two things that you can try relatively quickly:

  1. You may try to connect to your server by entering the IP address directly like "smb://<ip_address>" at the address bar on the file manager.

  2. Use another file manager like Nemo. Install with sudo apt install nemo and test.

I'm not sure if you need to install any additional software but try with these options, see if there's any luck.


If I understood and performed this right (Which is uncertain, heh); it did not solve my issue unfortunately.

Both 1. and 2. results in the same error prompt. Invalid argument. :confused:

Performing what was suggested here OMV6 - can SMB1 be enabled - CIFS/SMB - openmediavault DID solve my issue, or at least walked around it.

server min protocol=NT1

As I understand it, this is not optimal. I am more concerned about speed rather than strict security as it is within my own secured home network.

1 Like

Can you tried the solution from this other thread? The issue there was solved by working around some limitation with Nautilus:

Do you have net-tools installed? I had to install that to get ARP and nslookup going. Couldn't do anything by hostname before that.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.