Unable to boot from usb (try) core / lite in normal / safe graphics mode

Processor: Intel Core i5-10400
Motherboard: Gigabyte B560M H, bios version F6
Graphics card: Currently not installed
Boot usb: Sandisk Cruzer Blade

Newly purchased custom build PC, came with no OS installed. I've created a bootable usb using ventoy 1.0.74, with zorin's 16.1 core & lite 64b ISOs, as well as windows 10 21H2 and mint 20 cinnamon 64b.
Multiple attempts to install zorin core / lite in either standard or safe graphics mode have resulted in either black screen + hanging (numlock is on and unresponsive, no reaction whatsoever for 20+ minutes), or an instant reset without any boot messages appearing prior.
Mint's default trial has given a few messages, then auto reset; whereas its compatibility mode booted successfully, though I didn't attempt to install it thence.
Said messages included: machine check, failure creating named object \adbg, error communicating to tpm chip, unable to read config index 0 descriptor/start: -32, chopping to 0 config(s), can't read configurations, error -32. Can provide a transcript if necessary.
Windows' boot went mostly without a hitch, aside from a few odd resets (eg during setup after selecting keyboard layout).

Please advise on what else can be attempted to proceed with zorin's installation.

P.S: In the bios, disabled secure boot and fast boot. There's some "windows 10 features" setting supposedly related to secure boot, I've attempted to fiddle with that one as well to no avail.

P.P.S: Have since installed mint. This one only boots successfully from recovery mode -> resume boot.
Updating from kernel 5.4 to 5.13 fixed the display & boot issues for mint, but zorin still inaccessible.

On Mint, can you run in terminal:

sudo lshw -c video

and paste the output here?

Certainly.

*-display
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:128 memory:50000000-50ffffff memory:40000000-4fffffff ioport:4000(size=64) memory:c0000-dffff

If relevant, I'm using a somewhat old vga connected monitor, but connecting via hdmi to a fairly new TV screen resulted in the same.

That's about as generic as it gets...
Which kernel is working on Mint?

5.13.0-40-generic

That is what Zorin OS is currently using... I wonder if the .iso is still on 5.13.0-38...

Might the 15.3 iso be of use, then? I have that laying around, though the boot usb croaked for now.

My Hardware is Ryzen 5500U, latest Zorin OS Core iso worked flawlessly. are you using older one?

No, tried the 16.1 versions currently available on the website. I got the 15.3 a while back for virtualisation but hadn't tried it on this station.

Try a rolling release distro iso like fedora and see if it boots or windows 10 boots?

Bios Rev6 introduced capsulated boot for that board, I see that rev 7 & 8 had bug fixes and we're depreciated and replaced by rev9. It may be worth doing a bios upgrade, as Rev9 also has notes about fixing and adding driver compatibility noted for windows but if it's a firmware bug could affect Linux as well.

1 Like

Hello everyone.
Update: Have since obtained another boot usb, sandisk ultra 3.0, and gotten around to installing a GPU, MSI Ventus X3 RTX 3060.
Starting up both 16.1 versions with the 3060, safe or nvidia, resulted in the same frozen black screen as before.
On the other hand, version 15.3 (downloaded on 20/11/20) started perfectly well in safe mode, with or without the 3060 plugged in. Modern nvidia + 3060 resulted in a "black screen with blinking cursor" issue, which seems to have been mentioned in another post in december, though in relation to 16.1.
I went through with safe installation, drivers and all. Similar resume from recovery mode to boot and buggy display as in mint. Although I understand that in zorin I can't / shouldn't upgrade in place to 16 nor the kernel to 5.13?
Tried to change software & updates additional drivers from nouveau to nvidia 470 / 510, but it automatically reverts upon applying changes.

@seanhinkley In gigabyte's bios update software for windows, the only version which shows up for me is F6. And I'm frankly a little wary of attempting to flash a cutting edge version which follows up two consecutive buggy ones (assuming that's the reason they were hidden).

You are not able to upgrade to Zorin OS 16 from 15 at this time. The ZorinGroup is working on and developing a Direct Upgrade in place option.
You can install a higher kernel, though. I am currently using Liquorix 5.17.2 on my machine with Nvidia 3060 and having zero problems.

Coupled with the above black screen... This is very strange.
I do not see how it could be the Graphics card itself... Perhaps the MB?

@SBM I understand, I just noted it fixed some driver issues so I assume there is some firmware level incompatibility with something - it didn't really specify with what.

You should be able to upgrade the kernel 15 to 16 direct upgrade is not support yet, but you should be able to update the kernel.