Unable to Boot into Zorin OS in latest generation laptop (RP PIO log size 0 is invalid)

I have a Asus Tuf A17 (2022) with intel i7 12700H. I tried to install zorin in this laptop after disabling secure boot and fast startup, and the installation went perfectly.

However, after removing the installation media, I tried to boot into zorin, but I could not.

Every time I selected zorin from grub bootloader, this was showing:

(RP PIO log size 0 is invalid)

Generally people report that this goes away after a second(although on different configuration PCs). But for me, it was stuck there for hours.

I tried reinstalling multiple times and even did the hash check and everything seemed fine.

Does this have to do with some sort of incompatibility between ubuntu 20.04 and my processor? Because I then tried installing ubuntu 22.04, and everything seems fine. Please help, I just love zorin too much to let it go

Does this help?


Having searched on line this is a kernel bug which should be fixed when kernel 6.1 is released as error has been reported on multiple platforms and GNU/Linux OS's:


[Reference above sourced from: PCI error message during boot (mostly harmless) - #12 by Fraoch - Framework Laptop - Framework Community]

Thanks for responding, but the first solution didn't solve my problem. Also, comment number 53 works only if I could boot into zorin, but that's not happening. It gets stuck in this black screen and that's it

So that means we need to wait for an update right?

You should be able to edit the kernel string in the Grub menu, then if that works and once you're booted, edit the GRUB_CMDLINE_LINUX variable to make it permanent.

From the grub shell you can go through the process of upgrading your kernel to 6. As long as you follow the tutorial in the tutorials & guides category, and only install the necessary library, not upgrading all of the software (especially gnome).

1 Like

I recommend the TuxInvader LTS Mainline kernel:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.1


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.