(Unable to find a medium containing a live file system) while installing Zorin 16 pro

Recently I tried to install Zorin 16 from a bootable usb and faced with "Unable to find a medium containing a live file system" after Zorin 16 logo.
I also tried several things to solve the problem (changing the port, downloading another iso file, changing usb) and non of them worked!
What can I do guys?

1 Like

That is a very rare issue. Try verifying the hash value of the downloaded ISO file and make sure that the integrity of the file checks out.
A workaround solution may be to try booting from a USB 2.0 flash drive/port instead of USB 3.0
Change your BIOS mode to AHCI. That should fix your problem.

1 Like

Finally I realized the way to solve this problem!
I used Rufus to make a bootable usb but suddenly understood that it doesnt work properly so I decided to use Etcher instead.
and thats it :slight_smile:

2 Likes

There are several Etchers
Multiboot
Balena
Unetbootin
Rufus

Everyone swears by one or the other and all seem to work sometimes and not work others.
Balena has a habit of bricking USB drives.

1 Like

Etcher did a faulty flash on mine, windows could not reformat it (also not with diskpart) but there was a 3rd party program designed under windows that could reformat and recover the usb drive. I will look for that program again when i have found it.