Unable to find options to make desktop shortcuts for installed apps

I installed Zorin on my desktop after being highly impressed by how it ran on my 10-year-old laptop. I've noticed that the OS isn't offering me the option to create desktop shortcuts. I didn't have this issue in Manjaro Linux, Linux Mint, Peppermint OS, and, for a short while, Sparky Linux.

I looked it up in the forums. Most options suggest I head to the apps menu, right-click on the app I want to create a shortcut of, and click on the "create desktop shortcut" option. The trouble is, I am not even getting that option.

Some suggestions also involved me heading into the home/usr/share/application directory or (home/local/share/application) directory and manually creating a shortcut for an app. The trouble with the former is that I have no .usr folder present, even with the hidden files viewed, and the trouble with the latter is that the .local folder does contain the application subfolder, but it is empty and contains just an empty text file.

Unlike the previous Linux-based OSs that I tried, I was a bit lazy this time and didn't bother to create partitions manually. The previously tried OSs did have .usr folders (probably because I have manually created a separate home partition).

Please help me out on this. I am really impressed by Zorin and I intend to use it as a primary OS alongside Windows 11 (which is on a separate SSD FYI).

I'm still a newcomer to Linux-based systems, please go easy on me :smile:

If you right click the app in the list, or 'start' menu, does it not give an option to 'Add to Desktop'?

'Add to Favorites' will put a launcher on the taskbar fyi.

The /usr directory is in Root. You can locate it in the Zorin Core Nautilus File Manager by clicking "Other locations" in the left pane. Click "Computer" in the right pane. This will land you in Root.
You will have Read Only privileges unless you elevate the File Manager to root.
To do this, in terminal run

sudo -i

Enter your password. The prompt path will change to the root user path. Now launch the file manager:


You can then navigate with read/write access.

In Zorin OS Core, when you right click an application in the app menu, what options do you see in the context menu?

If you don't see those options, which would be weird, you still have the option to drag and drop the icon from the applications overview (the icon next to the Zorin Menu) into the taskbar. It's not exactly what you're after but may be enough.

1 Like

Agreed. And it may suggest that there is another issue that may cause the user headaches later. I do not recommend employing a workaround instead of a cure on this one.
Might just try a simple:

sudo apt install --reinstall zorin-os-desktop

If you right click the app in the list, or 'start' menu, does it not give an option to 'Add to Desktop'?

No, it does not.

'Add to Favorites' will put a launcher on the taskbar FYI.

Yes, and I do get that option. But I want to place some icons on the desktop. And I am not getting the option to do that particular thing.

OK so I managed to access the aforementioned folder(s) in the Zorin Core Nautilus files, but the application folder contains just text files. Where do I go from there? What do I do with them if I have to create desktop shortcuts?

The common options I get are "new window", "add to favorites" and "show details". I do get some extra options based on the type of app. But I do not have the option to create desktop shortcuts for any of them.

I can add shortcuts to the taskbar (panel) with no issues. I am getting the option to add it as a favorite into the taskbar. Granted it is a workaround of sorts. But it is effectively leaving the desktop unused. I just wanna get to the bottom of this glitch and resolve it.

1 Like


Just did that. It didn't resolve the issue.

OK so I just noticed that changing the DE allowed me access the "Add to desktop" option. Switched to a more tradition Microsoft Windows type DE and now I'm getting the option. Strange.

Also - check settings in Appearance under 'Desktop' with the other layout; desktop icons may have been disabled.

It's enabled. Not sure why it is only letting me add shortcuts to desktop when the Win 11 type DE is selected. Once the desktop shortcut's created, it remains on the desktop even if I switch the DEs.

Not exactly a direct solution, but hey... at least I am able to add desktop shortcuts... for now.

That is pretty strange .. lol

Glad it's working at least; have you ran any system updates yet?

I believe you are referring to Layouts here.

I think we have stumbled onto the probable cause (and fortunately, it is not something to worry about).

Gnome Desktop Environment disables Desktop Icons.
In order to revert this, the ZorinGroup added the Gnome Shell Extension "Desktop Icons"

Not all layouts will work with all gnome-shell-extensions.

1 Like

When using the Gnome desktop, you need to copy the desktop file of the application from /usr/share/applications to ~/Desktop.
An icon should appear on the Desktop.

To get the correct icon, and get the application to launch, you must mark the application executable in its Properties window. (right-click on the icon, select Properties, then open Permissions Tab and check the 'allow executing file as program' box.

OK so here's what I did further. I downloaded something called Extension Manager from the software store.

It allowed me to view the Zorin Menu icon right on the panel even when the GNOME DE is enabled. This effectively allows me to view installed apps and directly add icons to my desktop like I would on a traditional Microsoft Windows OS.

Now I don't have to switch DE's if I have to add a desktop shortcut of an app.

I did something better and more convenient. I downloaded something called Extension Manager from the software store.

Now I don't have to switch DE's if I have to add a desktop shortcut of an app.
-Please see solution above.-

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.