Unable to get list of updates

When I click on software, I get the following message: "Unable to get list of updates: The name :1.120 was not provided by any .service files." However, if I go through the terminal and type" sudo apt-get update", I get a list of files that need to be installed. Any ideas on how to fix the software app so that it can get the list of updates?

Search for Software Updater in the Menu Bar - run it but stop it to get the Settings button to show, select that, then a new window opens - choose Zorin Software Tab and to the right of Download from use the drop-down arrow and change to 'Main Server'. :wink:

You will be asked for your login password to elevate you to 'root' (administrator) to make the change.

Close Software and Updates and reload the cache - you may even need to restart Software Updater and be advised of a partial upgrade - do that first then look at running the updater again afterward. When you do the partial upgrade you will need to provide your login password again.

You will need to do a restart before doing anything else.

When you reboot and run software updater again it will run to remove the old Linux Headers - nice job Zorin Team!



sudo apt install --reinstall ca-certificates

I tried both suggestions but I still get the initial error message. However, when I refresh the software updater while it's running, I get a second error message: "E:Failed to fetch http://archive.ubuntu.com/ubuntu/distrs/focal/InRelease". FWIW, I am running Zorin 16.

This is odd... usually all of the above should work.
Have you rebooted?

Yes, I just tried that but it didn't fix the problem. I am now getting the following message

Uhh... Do you have secure Boot enabled?

Did you install the drive as Encrypted?

Are you dual booting Windows?

I did install this as a dual-boot system with Windows. In order to install Zorin, I needed to turn off Bitlocker (I think that is what it was called).

Ah, I see. That is a Windows LVM.

I wonder if @337harvey may have some pointers... I am woefully inept at Windows systems these days.

Well, thank you very much for your suggestions. I really appreciate the time you and @swarfender437 put into this. Hopefully, someone out there can figure this out!

FWIW, another update. This time, I completely shut down Zorin (I had pressed 'restart' before). When I started Zorin again and tried the software updater, I got "E:The repository 'cdrom://Zorin-OS 16 Core 64bit focal Release' does not have a Release file."

1 Like

Thatnks, this update helps.
Please open Software & Updates from the Zorin start menu.
Move to the "Other" tab.
Uncheck the box for CDROM:Zorin....

refresh. That will resolve that issue.

Will be interesting if that is what the trouble was all along.

Success! That did the trick. THANK YOU again!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.