Unable to get to desktop after login

I recently installed this gnome extention: Tilingnome - GNOME Shell Extensions . After installing it, some of icons and windows where glitching around and disappearing. I decided to see if I can restart to fix the issue but then, once I logged in, I was sent to a patterned screen (same pattern as on the login screen) and never got to the desktop. I am new to Linux so I am not sure what to do, and if I could somehow uninstall the expension (if that is even the cause of the problem).

Try holding down the left Shift Key at boot up in order to pull up the Recovery Menu.
When you see the recovery menu, arrow key down to the "Drop To Prompt" option.
Hit enter to proceed, then manually remove the extension with:

rm ~/.local/share/gnome-shell/extensions/tilingnome

Once done, back to the recovery menu and select to Resume Boot.
Please update this thread if successful or if unsuccessful.

1 Like

Tried this and it said "rm: cannot remove '/root/.local//share/gnome-shell/extension/tilingnome': No suck file or directory"

Ok please try the following. Replace $USER with your actual user name on your computer:

rm /home/$USER/.local/share/gnome-shell/extensions/tilingnome

1 Like

Again, it says no such file or directory.

Might just format my drive and install a different distro with cinnamon/xfce if there are no other solutions.

One of the more useful terminal commands is locate.
let's try that in your Recovery Prompt:

locate tilingnome

If the output shows the location, you can alter the rm command above to use that path, instead.

No need to do so if you want to. You can install XFCE desktop with:

sudo apt install xfce4

Once installed, you may then be able to log in on the XFCE desktop and manage the tilinggnome extension using a GUI method that is more familiar to you.

If you prefer Cinnamon:

sudo apt install cinnamon

For Basic Desktop:

sudo apt install cinnamon-core

For fuller and configured desktop:

sudo apt install cinnamon-desktop-environment

1 Like

Before you go that extreme, you could boot your system with a Live USB and try to delete this offending file externally. GNOME extensions should be located in your home directory - means not that difficult to remove.


I did not think of that... Very glad others are on here to add their brains.

Zorin OS Lite (XFCE) is an option (for extremes :smiley: )


I have been doing "locate tilingnome" and it simply did nothing. It's like t the command doesn't work or the file doesn't exist.

I will attempt this method tommorow, it's getting late here in Australia.

1 Like

We'll be here. Don't sweat it, I am sure we can get you fixed up.


Thanks, luckily I have all my files backed up on Google drive if all else fales.

I forgot to mention.
If you use Zorin Lite with XFCE desktop, tiling function is natively included. No need for an additional extension.

1 Like

So I have created a bootable USB with Zorin Lite and am currently in the home folder. I'm guessing ai have to go into the .local folder but when I try go into says "permission denied"...

In terminal type

sudo -i

When it elevates to root, type


to open the file manager with root elevation - this should allow you access to the files.

1 Like

Ok, thank you so much guys, it worked!

1 Like

Great - what was the actual location of the Tiling Extension? (For future reference)


1 Like

You can also enable "open folder as a root" function in options of Thunar. No terminal command required.


I just wanted to add one comment.

An incident like this makes me think twice before installing any extension in Gnome. One reason I choose Zorin is that its design is (almost) perfect for me and I do not have to do much customisation of my own.

For me, XFCE is a better playground for user customization than Gnome.