Unable to Install Grub (ZorinOS16 Lite) on SurfaceLaptopGo

BootRepair
I want to install Grub for ZorinOS16 Lite, but I get an error message and it does not work. I would appreciate it if you could tell me how to solve this problem.
(I am not good at English because I am Japanese. Sorry. )

Are you dual-booting alongside of Windows OS?
If so, is Windows "Fast boot" or "Fast startup up disabled in Control Panel > Power options?

No. Clean Install.

Hmmm... Odd. Looking over the Boot Repair Log that you linked to, I do not see anything troubling. It properly identified the EFI partition.
Are you able to boot into Zorin OS at all? Or are you currently booted into it?

I have tried many times to install. However, I get an Error message in the boot, and the UEFI starts up.
(Currently running on ZorinOS on USB.)

This may be caused by an error within the Windows drive that has remained and has never been corrected.
Have you tried fully formatting the drive first (ext4), then running the installer?
You can use the GParted tool in the LiveUSB of Zorin OS.

I did not know how to do this, so I used the Installer to format the file.

No problem, it is the same as using the installer.

In the LiveUSB, launch gparted from the app menu, or from alt+F2 or terminal with the command:

gparted

In the GUI window, select the partitions that were previous windows Partitions. Do Not Change the EFI partition for now. Just any other partitions.
You can select the partition, then click the delete button (-) to delete that partition. This will make it into Free space.
You can click the Free Space, then click the add (+) button. This will open a Formatter window.

I am very sorry to inform you, but I have been trying to install the software many times, and the Windows partitions have been removed...

I understand, but have you pre-formatted in the above described manner? Or only formatted during the installer as the user usually does?

SSD is Formatted in Installer....

Is it eMMC or nVME SSD? or SATA SSD?

eMMC Drive.
You can find my Computor's details here.(64GB Model)

1 Like

Ok, with eMMC, please check in your BIOS / EFI settings whether you are set to RAID or AHCI.
If switching the above still does not work, then please try my suggestion above of formatting the drive fully before running the installer...

Okay. I'll go confirm the UEFI settings.

I checked and there is no such entry in the UEFI...

mmmm... Probably because it is a Surface... Microsoft doesn't allow access. If I remember correctly, other Surface users have also said they could not access the RAID / AHCI switch...
Anything under "Devices" for "SATA Controller Mode"?

(I will be away from the computer for the next hour or so...)

I couldn't find any...

Konichiwa!

Try following this guide created for installing Linux Mint.

1 Like

Try using a Super Grub2 media to boot into the operating system. Link here: Super Grub2 Disk

1 Like