Unable to install hcxtools from source, openssl error

Hello there,

I'm facing a problem installing hcxtools using the official link https://github.com/ZerBea/hcxtools. during the make command, I get the following error


I have already installed libssl-dev.

some information that can be helpful.


I know it is not the right way to install packages but I have tried installing the .deb version from here https://debian.pkgs.org/12/debian-main-amd64/hcxtools_6.2.7-2_amd64.deb.html but I get this.


thanks in advance =)


I don't think you'll be able to install it on ZorinOS 16. The requirements page specify that you need several packages with a minimum versions that aren't supported yet in ZorinOS 16 which is based off of Ubuntu 20.04.

Some could be compiled separately to meet the demand but the most critical is libc6 currently at 2.31 while the minimum required is 2.34. This one you shouldn't try to update as it will definitely break other parts of the system that rely on the particular version currently installed.

  • distribution: recommended Arch Linux, but other distros should work, too (no support for other distributions).

Debian (e.g. Kali, Ubuntu) release requirements >= bookworm (testing/Debian 12)

This implies that you need to have a fairly up to date system using some sort of rolling-release model, which ZorinOS nor Ubuntu provide.

You should consider using one of those recommended distributions, perhaps through a virtual machine, or installed directly. Another option is to install an older release that is compatible with ZorinOS; it looks like v6.2.6 may be the one that was last supporting openssl 1.1 (another missing requirement) so I'd try that first.


Thank you very much @zenzen . the v6.2.6 didn't work for me, I had to go way back to v6.0.2 to get to work. I must say I didn't try every version, I kept jumping. but hcxtools v6.0.2 worked. thank you very much again for your help.


Keep an eye for the release of ZorinOS 17, which should be upcoming by the end of the year (no promises though). It will be based off Ubuntu 22.04 so it'd still not be able to run the latest version of this software but you may be able to take advantage of a more recent release.

1 Like

sure thing. any new update is a welcome.

Have you tried installing from apt? I have the packages available myself - for WiFite, works well!

apt search hcxtools should show the package, not sure what version though - works in Mint and Zorin :grin:

It's not showing for me :thinking: Did you update the kernel maybe?

Oopsie poopsie - misspoke .. I was using forensics-extra and hcxdumptool for WiFite; which didn't complain about hxctools in Zorin - forgot.. It did complain in other Ubuntu based distros, just not Zorin. Which I thought was a little weird..

Brain flatulence :expressionless: .. My bad!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.