Unable to launch chromium even if installed from terminal

Hello I'm on my father's old hp pavilion dv4000 with 2 GB of RAM and 60 GB of storage.
I installed zorin OS light 15.3 on it with the option erase disk and install zorin OS. That means that Windows XP is totally gone.

Problem : I can't install apps from the store app.
It works, but I can't launch them and when I reboot the computer, they're gone from the section 'installed' of the store app, but not from my desktop.

It's impossible to launch chromium from terminal too. Even if installed via the terminal using : sudo apt install chromium-browser.

When I type chromium-browser and click enter, it says illegal instruction...

I'm lost

I guess it's 32-bit version of Zorin you're running?
Can you please copy/paste the exact input/output of the terminal interaction?

1 Like

It's indeed 32 bit version of the OS.

I uninstalled chromium and tried again so I could copy-paste...

this is what i get now. It's different.

peter@peter-Pavilion-dv4000-EY774EA-UUG:~$ chromium-browser

Command 'chromium-browser' not found, but can be installed with:

sudo apt install chromium-browser

peter@peter-Pavilion-dv4000-EY774EA-UUG:~$ sudo apt install chromium-browser
[sudo] password for peter:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
chromium-browser-l10n chromium-codecs-ffmpeg-extra
Suggested packages:
webaccounts-chromium-extension unity-chromium-extension
The following NEW packages will be installed:
chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg-extra
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 75,6 MB/80,6 MB of archives.
After this operation, 272 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://nl.archive.ubuntu.com/ubuntu bionic-updates/universe i386 chromium-browser i386 91.0.4472.101-0ubuntu0.18.04.1 [75,6 MB]
Fetched 75,6 MB in 34s (2191 kB/s)
Selecting previously unselected package chromium-codecs-ffmpeg-extra.
(Reading database ... 279962 files and directories currently installed.)
Preparing to unpack .../chromium-codecs-ffmpeg-extra_91.0.4472.101-0ubuntu0.18.04.1_i386.deb ...
Unpacking chromium-codecs-ffmpeg-extra (91.0.4472.101-0ubuntu0.18.04.1) ...
Selecting previously unselected package chromium-browser.
Preparing to unpack .../chromium-browser_91.0.4472.101-0ubuntu0.18.04.1_i386.deb ...
Unpacking chromium-browser (91.0.4472.101-0ubuntu0.18.04.1) ...
Selecting previously unselected package chromium-browser-l10n.
Preparing to unpack .../chromium-browser-l10n_91.0.4472.101-0ubuntu0.18.04.1_all.deb ...
Unpacking chromium-browser-l10n (91.0.4472.101-0ubuntu0.18.04.1) ...
Setting up chromium-codecs-ffmpeg-extra (91.0.4472.101-0ubuntu0.18.04.1) ...
Setting up chromium-browser (91.0.4472.101-0ubuntu0.18.04.1) ...
Setting up chromium-browser-l10n (91.0.4472.101-0ubuntu0.18.04.1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2+zorin1) ...
Processing triggers for libc-bin (2.28-0ubuntu1+zorin4) ...
W: Operation was interrupted before it could finish
peter@peter-Pavilion-dv4000-EY774EA-UUG:~$ sudo apt install chromium-browser
Reading package lists... Done
Building dependency tree
Reading state information... Done
chromium-browser is already the newest version (91.0.4472.101-0ubuntu0.18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

and of course when i wrote "chromium-browser" again it showed "illegal instruction" again. But this time i was expecting it...

Thanks in advance !

32 bit package is not supported in the Main Universe Repo since Ubuntu 19.10. Not sure about 18.04, really...
You may want to run

sudo apt remove --purge chromium-browser

Then, for 32 bit Chromium:

sudo add-apt-repository ppa:canonical-chromium-builds/stage

sudo apt update

sudo apt install chromium-browser

1 Like

I did everything, then restarted the computer, but same result when I type chromium-browser I get illegal instruction. And when I click chromium it doesn't open...

By the way, never the icon of chromium went away from my computer. Even after uninstalled. And I have two icons of chromium in my start menu

Can you open terminal and run

snap list

and relay the output here? Does it list Chromium as a Snap?



flatpak list

I think chromium is a flatpak.

1 Like

Yes it does list chromium as a snap

Whichever it is...

snap remove chromium-browser


flapak remove chromium-browser

Reboot, then try launching Chromium from your App menu. Let's see what happens.

Snap remove chromium browser didn't work because the snap name of chromium is just chromium without -browser behind it.

So I did snap remove chromium. It's running for the moment.

1 Like

Ok, so Chromium is launching and working, now?

It's not finished removing yet

1 Like

Ah, he's done

I'm rebooting now

Doesn't launch. but the icon of one of the two chromium's has gone blank. It's still there but there's no chromium drawing on the icon anymore.

If I go to software> installed it's there and when I click it loads for a moment and then nothing happens, just like before

Let's remove from terminal, too

sudo apt remove --purge chromium-browser

The system may be confused by all these installations.
Check if chromium-browser is installed by any other means.
(this is where Synaptic is very useful...)
But you can select to remove from the Software Store.

Once all Chromium is gone, try installing it as a .deb file:

Save the package to Downloads.
Open terminal and enter (to change directory of the terminal)

cd ~/Downloads

Then (to install chromium .deb package)

sudo dpkg -i chromium_90.0.4430.212-1_i386.deb

This should install the .deb package for 32 bit Chromium. Watch the terminal for any errors in the output.

Ok I'll do that at another moment. Going to do something else now...

1 Like