Unable to load DaVinci Resolve home page

Hello,
I recently installed DaVinci Resolve (free version) on Zorin OS 17.1 Pro. I then had a problem: DaVinci launches normally but crashes as soon as the DaVinci startup window indicates: Loading projects. A 2nd window opens called Project Manager but there is nothing in it and my system tells me Resolve is not responding. I looked online, but couldn't find anything relevant, what should I do? I installed DaVinci Resolve 18.6. Thanks for future responses.

Does clicking Attendre (Wait) works or hangs again for long?

Thank you for your answer !
When I click wait DaVinci freezes again.

DaVinci Resolve tells nothing very specific of its minimum requirements, at DaVinci Resolve Download | Blackmagic Design it tells just 2 things for the Linux download. Here are its minimum requirements for a Linux OS:

  • CentOS 7.3 or newer version
  • 32 GB of system memory
  • Intel Core i7 or AMD Ryzen 7 CPU
  • Discrete GPU with a minimum of 2GB VRAM, supporting OpenCL 1.2 or CUDA 11 and equipped with the latest driver for Blackmagic Design Desktop Video (version 10.4.1 or later)
  • A high-speed Solid State Hard Drive (SSD)

Source :point_right: DaVinci Resolve System Requirements for Windows, Mac & Linux (2024 Update) - Postudio

Thank you for your answer !
No, my PC is compatible because before Zorin OS, I had Windows 11 Pro which was installed on my PC and DaVinci worked very well.

Which video card do you have? I'm asking because the Linux version only official support Nvidia cards.

I use this graphics card: AMD Radeon vega 8 graphics (model 2goVRAM)
My processor: AMD Ryzen 5 3500u

That may be the problem. Try search for "Ubuntu Da Vinci AMD cards", there may be some hoofs to make it work.

I searched, but unfortunately, you have to install the graphics card driver but on the AMD website, the version for Ubuntu 22.04 is no longer available and I already tried to install 23.40 but it broke Zorin OS and I had to reinstall Zorin OS. So I avoid trying to install AMD drivers.