Unable to maintain or 'lock-in' my audio output preferences

I'm hoping there is a simple fix for the following, I've tried searching for help online but everything seems to assume I want the opposite solution.

I want to use a headset purely for discord and similar usage - i.e. purely for voice calls.

However every time I plug in a headset Zorin switches to using it as the default audio output.

I've set the line out as "default" using the hack of a pactl line within the Startup Applications and that seems to ensure that line out is audio if the headset is already plugged in.

However if I plug in the headset "mid-session" it immediately steals all audio.

Windows (yes I know, I'm sorry, but ...) can set one output as system output and set the headset as default Communication output. Is there anything similar I can do within Zorin?

As I say, all trawling of the internet seems to turn up opposite results - how to send all sound to the headset.

This is a really good question.

I tried framing a net search in multiple ways on this - and had the same trouble you did. I kept getting results for the opposite of what you want. But - I wonder if reverse engineering the provided answers might help.

For example in alsamixer > F6 > NOT setting to auto mute - would that create what you want?

After making changes, save your preferred alsamixer setting using:

sudo alsactl store

1 Like

Tried a bunch of various things with alsamixer and while I can get it not to mute the line out I still get desktop sound coming through the headset which should only be used for voice comms.

So, you want System Sound to be routed through Speakers - Say, using your HDMI, whereas the LineOut jack only isolated to Discord or Zoom type apps, correct?

No, line out for system sound, game sounds, whatever.

USB headset, Discord, Zoom etc.

Solution found:


sudo sed -ri 's/^(load-module module-switch-on-.*$)/# \1/' /etc/pulse/default.pa

This stops the system from switching output when a device is plugged in, combined with using Startup Applications to set your default audio on power up - I finally have audio working the way I would expect.


I have bookmarked this solution in hopes of it being helpful to others.

Users seeking a resolution to Sound Switching is not an unusual issue.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.