Unable To Mount Seagate External Hard Drive

I am struggling to mount my external hard drive. It shows up in "disks" but I am unable to access it. Reformatting is out of the question as the hard drive has years worth of photos so I am looking for an answer from you good people about how to access the drive. I have seen others posting about the same issue but haven't seen any answers that have worked for them. The "smart data test" option in "disks" is not available to click on to check the hard drive which was an option I saw someone else post. Any and all help is welcome. Thank you.

Do you know what file format was used on that external drive?

You mean of the files on the drive such as jpeg?

No. I mean the drive formatting e.g. FAT, NTFS etc.

Partition 1 which features my content, I am not such but partition 2 which is empty is NTFS

Can we assume the basics like Windows Fast Start and BIOS Secure Boot were disabled prior to installation.

NTFS can be sometimes be fickle on linux.
We still dont know format of partition 1 containing your files though.
If you have Gparted (installed or on your Zorin bootable USB) use that to see if it tells you the formatting of that partition.

FYI. Another user had NTFS external drives that would not mount on ZorinOS, but after re-formatting again to NTFS and copying content back, did mount. Ref: Unable to mount HDDs - #41 by enstain

Maybe @337harvey can offer some advice.

Well the content on the device is not backed up elsewhere so reformatting is not an option. I do have another identical drive which mounts fine so I am going to go through them both on "disks" to look for any differences.

Can you mount that drive on Windows (If you have it) and see what partition 1 formatting was used?

Also, if not tried, plug drive in to a different USB port.

Is this Zorin 17 you are using?

Looking at my other seagate external hard drive which does mount with no issues, partition 1 on there also has an unknown format so clearly partition 1 having an unknown partition isn't the issue. I have just ran the "check filesystem" option in "disks" for the unmounted hard drive which states the drive "needs repairing" while the mounted one "is undamaged" so would you recommend I click "repair filesystem" or would that be a major risk of losing the content on the hard drive?
I have tried all 5 USB slots that I have and no joy sadly. It is Zorin 17 yes.

I would spend time to back up the content before doing a filesystem repair.
The repair may just affect the indexing not the files themselves, but best not to rely on that.

1 Like

Yeah honestly if I could get access to the drives contents then I would back them up onto the computers hard drive

OK. So guess you do not have dual-boot (Zorin/Windows) or another machine to do the backup copying?

Can you boot the ZorinOS installation USB.
Select "Try Zorin" option
See if the disk is mounted.

Well ZorinOS is completely installed on the computer, Windows is not an option for me at all. The odd thing is I can see the hard drive that won't mount and having gone through all the options in "disks" to compare the unmounted drive and the mounted drive they are identical, no clue at all why it won't load. I have contacted ZorinOS themselves who just redirected me here (good job I haven't paid for Pro).

If you do not have Pro you will not receive direct support from ZorinOS devs, only here on the forum.

Lets assume your photos and content files are intact on partition 1.
However, there is a reported filesystem error on that partition.
That may prevent it being Mounted on ZorinOS.

It is important not to rush into repairs or actions that may damage precious files that are not backed-up and loose them for ever.

I would take time out. Find a friend with a Windows machine and see if your external drive content can be seen on that. Then back that content up before doing anything else.

As I previously stated, NTFS can be sometimes be tricky on linux.
Whilst I suspect your problem may be a simple indexing corruption, we dont know that for sure. Best to be safe than sorry. Zab

1 Like

Thank you for the help

Someone else may see this and have other ideas that may help you.
Also do report back if you find a fix elsewhere. Just be careful with data that is not backed up.

Bit the bullet....... hit "repair filesystem" (with my eyes closed) and Bob's your Uncle, F###y's your Aunt, we are back in. Thank you for the help guys.

That was a Casino moment for sure. I am glad the house paid out on this occassion.

You know what to do now. BACK IT UP! :exploding_head:

1 Like

Oh yes, backing it up onto the desktop is what I am currently doing now.

1 Like