Unable to Print To an HP Laserjet

I am unable to print on my HP Laserjet Pro MFP M28w
I have the printers package installed and have configured it.
I am attaching a few screen prints incuding showing the print queue with a Test Page print just processing and nothing else.

I deleted that and tired to print a document using Libre Office Writer and the same problem.

I can print to the this via Windows 10 running on Virtual Box on the same Zorin Core 16 with no problem.
I have been using the Windows VM to print, but I dont want to be using this all the time.


Maybe this will help:

I have history with this package called HPLIP. About 2 years ago I tried to get it to work without success and it was one of the reasons I went back to Windows.

However I was willing and still am to try and get this to work at least in part. I dont have to have the scanning option working as I dont do that much and I can always use the Windows VM for that.

So I ran the HPLIP 3.22.2 package and it worked really well as it picked up Zorin 16 as the OS.

It failed when it came to the HP-SETUP part.

Import Error: /usr/lib/python3/dist-packages/hpmudext.cpython-38-x86_64-linux-gnu.so: undefined symbol: mdns_lookup

Then a cascade of other errors follow on. I am attaching a screen shot to show how this happens.

I have done a search obviously on the web and although someone else had this exact error during Feb this year 2022. The issue has not had any feedback yet on bugs on Launchpad Bug #1852169 “Error when installing.” : Bugs : HPLIP

I have asked the person did they find a solution for their problem and are awaiting feedback.

The HP documentation on their site is rudimentary as does not cover if anything goes wrong.

So I will see further what I can do and let you know. If anyone has any bright ideas I am all ears.

I found some topics marked as Solved:


You probably have seen these...

It is similar but very old from 2009. It also does not list how he found the old modules that needed removing. It is obviously similar but where to start looking for the modules and more importantly which ones. I can start looking for mdns_lookup but I dont know which version is the one that should be used?

Do you have a link available?

This is the link to my first statement about a similiar issue ;

I didn't get any resolution, or pointers from the HPLIP developers. It seems to be caused by some packages having become obsolete, but I couldn't find them, even to compile from source, and add them.
Then Paul Hands reply:-
What's kind of frustrating is that HPLIP 3.21.10 works just fine on SuSE Tumbleweed, and that's a much more bleeding-edge distro than the KDE Neon I was using when I got those errors.

This is the link to the second mention https://www.linuxquestions.org/questions/linux-newbie-8/hplip-source-make-error-882033/ in which there is no detail about which modules to delete.

Did you check any of the three links I posted? There may be helpful suggestions, there.

Based on some research the hp-check This is the one major error.

error: hpmudext IO-Extension REQUIRED - 3.22.2 MISSING 'Not Found or Failed to load, Please reinstall HPLIP'

I will carry on tomorrow.

1 Like

That leads to:

sudo apt install python3-pip

sudo apt install --assume-yes python3-pyqt5

sudo apt install --assume-yes python3-dbus.mainloop.pyqt5

sudo apt install --assume-yes python3-notify

Then run the .sh for hplip, followed with

sudo apt install libcanberra-gtk-module

Please also scroll down to the other tips here:

Yes I did. They have given the HP-Check to run which has been useful but I need to go through output as it produces a lot of stuff and the documentation for this routine is not good. It has multiple options to use.

I will run hplip install tomorrow. I have now installed the NET-SNMP module as suggested to solve the HP error linked to hpmudext IO-Extension REQUIRED

1 Like

I get this error on the last command listed above "sudo apt install --assume-yes python3-notify"

Package python3-notify is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'python3-notify' has no installation candidate

This is the output from the 4 above commands:-

Since installation, have you yet run

sudo apt update && sudo apt upgrade

In Software & Updates are you set to Main Server?

The first question:- No I have not run sudo apt update ..
Second:- How can I check if they are set to Main Server?

sudo apt update && sudo apt upgrade
[sudo] password for raymond:         
Hit:1 http://gb.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu focal InRelease    
Hit:3 http://gb.archive.ubuntu.com/ubuntu focal-updates InRelease              
Hit:4 http://gb.archive.ubuntu.com/ubuntu focal-backports InRelease            
Hit:5 http://ppa.launchpad.net/zorinos/apps/ubuntu focal InRelease             
Hit:6 http://ppa.launchpad.net/zorinos/drivers/ubuntu focal InRelease          
Hit:7 http://ppa.launchpad.net/zorinos/patches/ubuntu focal InRelease          
Get:8 https://packages.microsoft.com/repos/edge stable InRelease [7,342 B]     
Hit:9 http://ppa.launchpad.net/zorinos/stable/ubuntu focal InRelease           
Hit:10 http://security.ubuntu.com/ubuntu focal-security InRelease              
Hit:11 https://repo.radeon.com/amdgpu/21.50/ubuntu focal InRelease             
Hit:12 https://repo.radeon.com/rocm/apt/5.0 ubuntu InRelease                
Hit:13 https://packages.zorinos.com/stable focal InRelease                  
Err:8 https://packages.microsoft.com/repos/edge stable InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
Hit:14 https://packages.zorinos.com/patches focal InRelease
Hit:15 https://packages.zorinos.com/apps focal InRelease
Hit:16 https://packages.zorinos.com/drivers focal InRelease
Reading package lists... Done
W: GPG error: https://packages.microsoft.com/repos/edge stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EB3E94ADBE1229CF
E: The repository 'https://packages.microsoft.com/repos/edge stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

What does the above command do and what should/could it help?

There is an app called Software & Updates where you can check.

By the way you should add the public key for Microsoft Edge. Here is the tutorial:

1 Like

Thanks for the PUBKEY information. I am still getting back into Linux.
What do I put in the place of the XXXXXXXXX . It says it needs a KEY ID?

You should see the pubkey in the error which is displayed when you run sudo apt update

Yes Software & Updates are set to zorin_os-focal-main

On the first tab, about halfway down, you should see "Download From". Next to this is a Drop Down Menu, where you can select "Main Server".

1 Like