Unable to record

Does anyone know how to get an input to record? I'm using Zorin Lite. When I click on the speaker symbol on the taskbar I can call up the mixer. It shows a good signal coming in from "Built-in Audio Analog Stereo, Port: Microphone: plugged in", when I tap on the mic. But I hear nothing, and when I use the simple "Sound Recorder" that came with Zorin, nothing shows it as getting a recording signal when I hit record and nothing records. I also tried to use "Audacity" but no signal comes in or shows on a recording. I went through all the different possible mic inputs in "Audacity" but none show a signal. As a reminder, when I go tho the system audio mixer (from the taskbar speaker symbol) I can see a good input when I tap on the mic.


Open the terminal and type alsamixer
Press F6 to select audio card.
Then make adjustment to the mic. It might set low or muted.

Thanks for your response. In the alsamixer it was on "default". Well, I don't know why I needed to select the sound card since I was already getting a sound output to speakers on default - but I selected the sound card anyways. This seemed to make no change to anything as far as I could tell. I figured out how to get the mic value to change on the alsamixer (use the arrow keys to select "mic" and then increase the value)... But after increasing the value to 100% on the mic, still nothing records (whether set to "sound card" or "default"). But as I said before - on the mixer that comes up from the task bar (not the alsamixer), it always showed a response when I tapped the mic anyways - the indicator bar leaped with each tap. And why did the task bar mixer show activity if the alsamixer said "0"?? I guess I don't really understand Linux. Anyhow, changes to the mic value on the alsamixer didn't fix it - I still don't know how to get a mic recording.

You could try it with PulseAudio Volume Control. It is a graphical Interface to adjust Input and Output Stuff. If you want to try it open the Terminal and type:

sudo apt install pavucontrol

After You installed it You should find it in the Multimedia Category from the Start Menu.

There may be more than one "mic" channel in alsamixer. If any showing [MM] unmute by typing "M" (no quotes) and raise the volume. I would do that for all input channels.

There is only one "mic" channel in alsamixer. I tried turning all the "line in" channels all the way to 100 too, but still no recording when I use the simple sound recorder (the one that came with Zorin). I also tried using several other recorders. What's frustrating is that there is a mic signal coming in (so it's not a problem with the mic) since it shows it leaping in the audio mixer when I tap the mic. The audio mixer I'm referring to is the one I can call up from the taskbar (see the image I uploaded). You can see where it says Microphone (plugged in), and even the white line at the bottom that leaps when I tap the mic (just above where it says "Advanced" on the bottom (clicking advanced simply allows for adjusting latency).


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.