Unable to Remove FreeCAD

Hello everyone!

I'm on Zorin OS Pro.

I already removed FreeCAD. But it's still there and I'm able to open it!

I tried everything mentioned here: How to uninstall or remove freecad software package from Ubuntu 17.04 (Zesty Zapus)

Still no luck!

Any solution?


How did you install FreeCAD ?

I didn't. It came with Zorin OS Pro! That's why I need to remove :frowning:

I just noticed, Scribus also got the same issue. Removed, but still there!

When you open Software store for Installed software, what does it show for those 2 apps. Particularly are they apt, Snap, Flatpak etc?

The software simply opens without any issues!

Really bugs me! I tried every possible way to get those software removed!

So are thet Snap or Flatpak?

As I mentioned, I didn't installed those software. It came with the Zorin OS Pro.

I just checked my installation of Zorin 16 Pro.
It is called LibreCAD and installed as an apt package.

Issue the following command in terminal:

sudo apt purge librecad

akhil@akhil-HP-ENVY-Laptop-13-ah0xxx:~/Desktop$ sudo apt purge librecad
[sudo] password for akhil:            
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libmuparser2v5 librecad-data
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 8,648 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 271724 files and directories currently installed.)
Removing librecad (2.1.3-1.2build1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...

No luck!

Now I understand.
I confused LibreCAD with Free CAD.
Silly me.

FreeCAD is installed as a Flatpak.
You meed to remove it in FlatPak.

flatpak uninstall {app name}

Seems didn't work! I'm I doing correct?

Can you check the list of installed Flatpak?

flatpak list

1 Like

That is why I asked if it was a Snap or Flatpak, as they are uninstalled different from apt.

Your screenshot above indicates "Uninstall complete." So assume it worked.

1 Like

Remember the good old days?
There was only apt nothing more, nothing less :roll_eyes:


I see no FreeCAD in this list.
It should be gone by now.

Nor is Scribus in that list of Flatpak's so is that a Snap by any chance @FrenchPress ?
(I dont have Z16 Pro so can't answer myself)

1 Like

As far as I can tell from my installation of Zorin16 Pro, both are Flatpak.

1 Like

The Icon is still there, you can see "FreeCAD". When I click on it that, the mouse pointer turns to "loading" and it keeps load...!