Unable to set Opera as default browser

I installed Opera from the software app. I opened it, and went through the instructions, and confirmed my email address. I then logged in, but could never get past the first page. I filled in all the information, my name location etc, but it would go no further than that. I tried going into settings and making Opera my default browser. I then restarted my computer just to make sure that was not the problem. Once again, Opera was not showing in the taskbar, and Firefox still was. Does anyone have any ideas what I am doing wrong?

You can try to go into Settings -> Default Applications, and select Opera from there as the default browser (web), instead of Firefox.

1 Like

OK did that, but to use Opera, I still have to select it from the apps list. Only firefox shows on the taskbar. I however have decided to stick with Firefox because some of my saved websites, do not allow me access when using Opera.

If you right-click on the icon, either while it's running or from the application menu when you search for it, you should see a "pin to dash" option.