Unable to start programs on the discrete intel arc gpu

Greetings
I installed Zorin OS 17 Pro on my Asus Notebook but I have minor issues with the discrete graphics card.

My Hardware:
Asus UP6502
12th Gen Intel® Core™ i7-12700H × 20
Mesa Intel® Arc(tm) A370M Graphics (DG2) / Mesa Intel® Graphics (ADL GT2)

So my issue is now, that I am unable to start games with the discrete graphics card. I tried "simple" games and more demanding games.

For example I have steam standalone installed with Proton-GE8-30. I've tried to run satisfactory, alien isolation or just minecraft(not via steam). But every game starts on the integrated graphics unit.

I've installed the intel drivers

I've tried to start the games via the "Launch using Discrete Graphics Card"
image

But that does not seem to work. Some games that tell you which GPU they use is always the ADL GT2 iGPU.

I've checked the drm devices and there are two cards. card0and card1
I've monitored both via intel-gpu-top, but only card0 shows activity in idle or when I run a game.
But tbf, I am not sure whether that is any helpful.

I hope someone can help me, it's quite exhausting trying to play with the igpu

From this, it looks like the A370M Arc is your Integrated Graphics. I do not see a listing for Dedicated Graphics card like Nvidia or AMD. Can you please check on this and clarify what your Dedicated Graphics card is?

Greetings
the Intel Arc A370M is a dedicated GPU from Intel made for mobile. It's from their new arc lineup they published 2022.
The integrated GPU is the Intel® Iris® Xe Graphics from the i7-12700H

1 Like

And I see above that you followed the steps to ensure the drivers are installed.

Do you have Secure Boot disabled in the BIOS / EFI settings?

Nope, Secure Boot is enabled

I also ensured that there isn't any option to disable the iGPU in the. The laptop does not allow disabling the iGPU in the UEFI

I would try this with Secure Boot disabled.
If you are dual booting with Windows OS, then we may need to find a more permanent solution.

Alrighty, I will try this
I currently don't use dual boot.

If not using (dual boot) Windows OS, there is no need for Secure Boot.

Ubuntu and derivatives include MOKsetup in order to allow for use of Secure Boot with Windows.

That seems to be the solution. I disabled secure but, ensured that it's disabled via sudo mokutil --sb and it works. The games I want to start, start via the discrete gpu and without issues. intel-gpu-top shows that the GPU is being utilized and the games I play also show that they use the arc instead of the igpu

Thanks for your help!

2 Likes