Unable to use hard disks and partitions after installing zorin os

Hello, i am new to Linux. Previously i had WIndows 10 with 4 partitions. I had one 250gb ssd, two 1tb hard drives and one 500gb hard drive in my laptop.
I installed zorin os replacing windows 10 on My C drive which was the ssd. I have single boot zorin os now.
Now, i am able to use the c drive(ssd) properly but not the other drives. I am not able to save files or create folders or upload files from other partitions. I still have the old files saved in the d e and f drives which i am able to play.

First, lets begin with the most easiest thing to check. Please go into your computer's BIOS and make sure that SECURE BOOT is disabled. Once disabled, if you are still having issues, this could be due to the fact that you might be using an NTFS partition.

I strongly recommend that the drive be formated using GPT, and then then install Zorin OS. If you are not dual booting into Windows, there is no good reason to keep an NTFS partition file system, it doesn't work well with Linux.

So, again, please check to make sure SECURE BOOT is disabled first. You can also see your drives partitions in the APP that comes with Linux called DISKS.


Thank you for a quick reply. I do not have dual booting. I opted for single boot while installing zorin os.

I see. But I am sure you never formatted the hard drive before installing Zorin OS. And as you said in your post, you did install it on the C drive, that is the part that tells me you installed it on an NTFS partition already on the drive.

I know you may not want to do this, but since you are already starting fresh as it is on Zorin OS, I would recommend installing it over again. Except, this time, I want you to format the entire hard drive to GPT, before installing Zorin OS. These are the steps to doing that.

Boot off of your USB flash drive that has the Zorin installer on it. Once you are at the screen that provides the two choices, choose TRY ZORIN OS.

Then I want you to load up DISKS. Click Zorin :zorin: logo, type DISKS, click on it.

Make absolutely sure that you select your hard drive (Not the USB drive!) on the left side list. Once you have selected the proper drive....

On the right side of the window, you will see 3 dots in vertical alignment. Click on those 3 dots, and click on FORMAT DISK. Select partition type GPT, give the volume a short name. Proceed to format.

Once the format is complete, boot up the installer again, and install Zorin OS onto your hard drive.

Again, I know, you may not want to do this all over again. But if you want to do this correctly, and have a better experience on Linux, you must do this.


This can happen when windows assigns ownership on the ntfs partition.... especially if the partitions were created in the mbr disk type. There is a fix but involves editing the /etc/fstab 's mount permissions and the fs type.

A common set of mount options for ntfs is uid=1000,gid=1000,dmask=027,fmask=137. This sets you as the owner of the drive, and sets the permissions to drwxr-x---.

Or you can edit the partition entry including an alternative fs entry with the permissions keyword that will allow you to change ownership and set Linux permissions:

/dev/sda2 /mnt/excess ntfs-3g permissions,locale=en_US.utf8 0 2
4 Likes