Unable to use my printer (HP Color Laser 150a) with Zorin OS

Hi guys, I've been trying to configure my printer as described above for a few days. I've already tried the following Printers and Scanners - Zorin Help . The printer is also found and I don't really have to add it, but I can't find the right driver for the printer. Has anyone been able to solve similar problems before? or can help me? I'm a total beginner with Zorin Os so I need a step-by-step guide. Thanks very much!

Have you tried downloading linux driver from HP website. HP Color Laser 150a Software and Driver Downloads | HP® Customer Support

I've visited this page before, but wasn't sure if that's the purpose of Zorin Os to download software from a proprietary provider.

Sometimes proprietary drivers are the only way to make the hardware work as intended, with all of the features offered. Linux is still in the process of gaining the support of hw manufacturers. Until then, someone either has to reverse engineer drivers or proprietary are the only two options.

If you are able to reverse engineer the driver, in order to provide a FOSS version, that would be great. Otherwise, proprietary is what you have to do to make it work.

Yeah, this makes sense. I am unable to reverse engineer, so I had to dl the proprietary software https://ftp.hp.com/pub/softlib/software13/printers/CLP150/uld-hp_V1.00.39.12_00.15.tar.gz

What next?

Google is your friend, found it in 2 seconds. All info can be found here

I don't use google, so thanks for the post! I now have the correct driver. The network address was also submitted automatically, although I'm not yet sure whether it's the right one. I feel like I'm already very close to the solution, but it still fails at the point that the printer status is running during execution - Processing page 1... doesn't continue or no test page is printed in the troubleshoot.txt something says {'cups_connection_failure': False }. Can somebody help me with it?

I have already installed the driver from this site, as I said, the printer just doesn't do anything with the printer status
"Executing - Processing page 1..."

I don't have a HP printer, but there is a download called HPLIP for HP Printers and Linux. If you do not have that already, you can find it here: https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

You should see "Zorin" in the list of Distro's

Also if Ubuntu is listed and Zorin is not, you can still install it - Zorin is Ubuntu based.

"Zorin" was actually listed in the dropdown list when I went there (that surprised me). But yes, normally you would look for Ubuntu as nearest fit.

Yes, I have already downloaded and installed an Ubuntu HIPLIP version. Maybe not the right one yet. At least it shows me that it doesn't recognize a system tray. In a quiet minute I'll take a look at the links that have been shared here. I thank you in advance. Merry Christmas and a Happy New Year!