Unbind Ctrl+Alt+[Left | Right]

I'm on Zorin 16.1 Core. An application I use maps Ctrl+Alt+Left (similarly Right) to a set of actions in the application. However, these shortcuts don't work under Zorin.

To investigate why, I opened a keyboard testing website and it doesn't register me pressing Ctrl+Alt+Left simultaneously. Each key works fine pressed individually though. This is not a hardware issue, as this is an N-Key rollover keyboard, and the shortcut works fine in Windows.

This suggests to me that Zorin/GNOME is intercepting this shortcut. However, no such shortcut is listed in Settings > Keyboard Shortcuts. I found a similar issue on askubuntu.com, but the solutions presented there didn't work for me. Any idea how to fix this?

Be default, the ctrl+alt+left-right arrow keys are used for switching Workspaces.
I wonder if this may be a clue as to why you are unable to use them, currently.

Yes, that was mentioned in the issue I linked. I just haven't had any luck disabling the shortcut. Zorin doesn't even support left/right workspaces though, so it's odd that this shortcut exists by default.

Must be a difference between Gnome (Zorin OS Core) and XFCE (Zorin OS Lite)
I use Zorin OS Lite, and the keyboard shortcut for workspace switcher works.

In Gnome, you might have some luck installing Gnome Tweak tool

sudo apt install gnome-tweaks

And changing the workspace switcher from Dynamic to static.
Once done, log back in and try changing the keyboard shortcut.

Or, try examining your shorctuts

gsettings list-recursively org.gnome.desktop.wm.keybindings

and change

gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-down "[]"

I installed gnome-tweaks, enabled the "Static Workspaces" option, and logged back in, but there was still no shortcut listed in Settings for switching workspaces left or right.

Interestingly, I tried enabling the "Horizontal workspaces" extension in GNOME Tweaks, and indeed Ctrl-Alt-[Left | Right] function for switching left and right between workspaces. Still, these shortcuts don't appear in Settings.

As for using gsetting to clear the shortcut, I had already tried that, as that was suggested in that page I linked earlier.

I ran

gsettings list-recursively org.gnome.desktop.wm.keybindings

And this was the output: https://pastebin.com/9c0CpkvC

Looking at that output, it doesn't seem to match at all what I have configured in Settings. For example, it shows the close action as Alt+F4, but I have it set as Super+Q. So it look to me like the Settings application is saving the shortcuts somewhere else.

1 Like

Perhaps @Storm or @Elegant_Emperor or another user who is much better with Gnome Desktop than I am can be more helpful.

Maybe its the application which has the problem. I would like to know which application it is and the method you used to install it. Most apps have the settings to modify keybindings within them.

CLion, installed through the JetBrains Toolbox App. The Toolbox App was downloaded from its webpage.

I'm certain it's not CLion that has the issue though, as I can reproduce the problem on the keyboard testing website, as mentioned.

There is no keyboard shortcut as ctrl+alt+[left|right] in toolbox according to their website:

However, I tried to reproduce this in Pop!_OS and the shortcut did not work on my side either.

The shortcut is for CLion, not the Toolbox App.

The shortcut does not exist in CLion either. Go to Help->Keyboard Shortcuts pdf; and you can see all the available keyboard shortcuts. I did not find any settings in CLion to modify the shortcuts either so I don't think that the shortcuts were changed.

The shortcut exists. It is part of my keymap (which is customizable in Settings > Keymap).

Anyways, there's a reason I didn't mention CLion in my initial post: it's irrelevant. I can reproduce the issue outside of CLion, on the keyboard testing website using Chrome. Not only that, when I enabled "Horizontal workspaces" as described above, I confirmed that Ctrl+Alt+[Left | Right] is bound to workspace switching. That is the issue.

To be clear, I appreciate your help, I just want to get across that the issue is not with CLion, so discussing CLion won't get us anywhere.

1 Like

I finally got this issue fixed. Using dconf Editor, I found the problematic keybinds at /org/gnome/desktop/wm/keybindings/switch-to-workspace-[left | right]. Clearing those keybinds by setting them to [] resolved my problem.