Unknown Display after update (AMD Ryzen 5 4500U)

Hi everyone, I'm posting this from an amazing real estate of 800x600 (honestly it's quite hard here, I'm glad there's a full screen editor mode).

I have this Tuxedo Nano Pro Gen11 with an HDMI 14" 4K touchscreen. I had it all working quite well until I decided to install all updates and reboot today (because it had been at least a couple of weeks before I had done that). Unfortunately, after the reboot, the display is no longer recognized and so I can't change the resolution or anything about it. Not even forcing to, via xandr.

I've tried going back to the previous kernel, but that didn't work. I even tried installing one from a while back, to no avail. I also reinstalled the latest one.

The drivers seem to be correct and the graphics card is properly detected. I've also tried proprietary drivers, and different HDMI cables (even a new one I had in the plastic bag), to the same result. I have no idea how to fix this and I need my 4K resolution here.

Below is my inxi -G and screenshots from other things that might be useful:

Graphics:
  Device-1: AMD Renoir driver: N/A 
  Display: x11 server: X.Org 1.20.13 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa resolution: 800x600~75Hz 
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.2.6 

Screenshot from 2022-03-13 18-00-28

Thank you for any help or tips you can provide!

Do you have AMD Dedicated and Intel integrated? Or just AMD?

1 Like

No to both. :sweat_smile: Integrated AMD. :blush:

You may need to install the AMD GPU driver manually.
First, let's try from repository...

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Reboot and test... if no good, will need to download the amdgpu.tar and follow the yellow brick road...

1 Like

Thanks! I've tried both of those, however, the amdgpu-install (if that's what you mean by amdgpu.tar, if not, what do you mean?) one actually can't get through because it complains that zorin isn't a valid distribution (the script actually looks for ubuntu in /etc/os-release:NAME or something like that). I changed the script but it still broke further down the line.

Any other ideas? :confused:

Yes, I was referring to the .tar.gz downloadable from the AMD website.
Yes... The AMD Devs rather lazily scripted it to only look for the Main Distros... rather than to check the lsb-release file as any sensible Garden Rock would have coded it to do.
The only way I know of to get around it currently is to change it to Zorin Instead of Ubuntu in the script.
Can you paste the output of where it breaks further down the line?

1 Like

Ok, I can't do it anymore today, but I'll get around to it tomorrow and paste here.

So... Something interesting happened. I installed the amdgpu-install thing again, but it "worked" this time. I suppose something changed or I messed something up before.

Now the resolution is 4K again, but the screen is all garbled up (impossible to read) apart from the top bar and dock (I can click). I can't see anything inside any windows.

I've tried to run sudo apt-get update && sudo apt-get upgrade successfully (I believe), but still having the same issue. I can't even properly use the terminal to try some other commands, but am open to suggestions (I haven't tried recovery mode from grub, but I imagine that'll work with the same 800x600 resolution as before).

Here's a photo of the screen (can't attach a screenshot), and don't be fooled by the readable first line. It's a lie as it doesn't update as I type (the screen does jitter):

I would definitely consider this a Graphics Driver issue.
From Recovery Prompt, you may try the edge HWE kernel:

sudo apt install linux-generic-hwe-20.04-edge

1 Like

Thanks, that didn't work, I had the exact same result. Should I try removing amdgpu-install from the recovery root shell/prompt? I installed it as a user, not root, so I might need to sudo su - user, right?

It may be worth trying... But I would not hedge any bets at it making any difference. The files must be placed in the appropriate directory - so if it was unable to due to a permissions issue, the installation of the driver would have simply failed.

Have you checked your Blacklist?

1 Like

So, I just got it solved after booting into the latest kernel (linux-image-5.13.0-35-generic) in recovery mode, running sudo su - myuser and amdgpu-uninstall then reboot. It was just simply everything ok afterwards and I can't quite explain it.

Maybe in the process of installing and uninstalling the drivers something got fixed somewhere?!

I then proceeded to remove all the unused kernels and finish cleaning up (sudo apt-get purge amdgpu-install).

After rebooting a couple of times (normally, into the latest and only kernel), it's all still working fine. :man_shrugging:

1 Like

Out of curiosity, what did you mean with the "blacklist"? apt-mark hold/unhold?

Check in /etc/modprobe.d/blacklist for the blacklist file.

1 Like

There seems to be a lot of stuff there (files, and also in the contents of blacklist.conf). Anything in specific I should be looking for?

Not anymore... since you got it working and the issue was not a blacklisted module. :wink:
But what that was about was if a module you need was blacklisted, then you could remove it from the blacklist in order to allow it to work.

1 Like

Thanks, I was hoping you could mention a module that could be problematic to be whitelisted, but I get what you're saying. Thanks again a ton @Aravisian !

I hear you... But without doing a lot of searching for all that my brain does not contain, I would have no idea. :wink:
Checking the blacklist would give us names of modules we could research to see if there were any that should not be on the blacklist.
But off the top of my head? I do not deserve that much credit...

1 Like