Unlocking my USB 'read only'

I did find, and tried to follow, a previous forum post -

"Can't use my USB. Read-only file system?"

But got lost in the daisy chain of instructions AND that is a locked post so I'm creating a 'new' question here to see if I can get this USB stick UNlocked from Read-only. (short of taking a hammer to it - lol)

I did look at diskdigger.org but that is where the wheels fell off the cart -
I see diskdigger.exe in my download files. but when I try to put this into the terminal - sudo mono diskdigger.exe - it says no such file or directory exists.

Its amazing to me that a 'simple' USB device can become 'read only' but can't as simply be changed back to normal operational mode.

Any hints will be greatly appreciated.

I have stumbled upon this myself.

I was on windows 11 back then, so i installed EaseUS Partition Master. Select the USB drive and format it with the proper file system and then i was good to go.

The issue for me was Balena Etcher, so i won't be using that anymore. This happened 6 times in a row, which is why i figured it was BEtcher ^^

1 Like

Thanks for your feedback freshjeff - but I am so NOT wanting to re-format my USB since then I would lose all the files on it that I want to keep!

I'm pretty sure that the USB stick got messed up by (cuss words) Windows which sadly cripples along with a decent and SIMPLE photo editing program that I use now and then. The problem came when that Windows (7) program would NOT 'eject' the USB stick and probably messed up files when I finally did the 'under achiever release' (pulled it OUT).

But what gives Windows the right to READ ONLY the entire USB stick?? (muttering to self again).

So here I am and slowly grinding teeth in search of path back to usability for files so I CAN back them up and - perhaps?!? - continue using this hunk of storage media . . .

You could copy them to the internal hard drive of your computer, format the USB drive, and move the files back to it when it's fixed

Read-only should still allow to copy files from it to outside

3 Likes

When You can copy the Files like @Sorro suggested, You could use DiskPart in Windows to make the Stick usable again.

I will give that a try Sorro. Fingers crossed it will work! Ponce - I only have Zorin on this computer, the Windows 7 laptop I have is very limited. I tried to use DiskPart on it and could not find the 'unlock' there that was suggested in one of the sites I've looked at.

It isn't directly an unlock. It is more like a complete delete and reset. That is the Reason why I wrote this with ''copy the Files''. You would first copy the Files, then I could give You the steps that You need and then You could pack the Files back to the Stick.

Been slow to get back to this task for a few reasons - want to buy NEW USB sticks and transfer all files to one.

At first I would not even copy /transfer a file off of the (bad) stick. I then changed the Properties (Share) to 'all' and was able to move a file to my Desktop. I could then attach that (photo) file to an email and it sent fine. However I still could NOT 'save' that attachment. So I am a bit hesitant to do all my (photo) files until I can return my ability to do with those as I want. Grrr computers deciding for me :stuck_out_tongue_winking_eye:

Could there be a hang up regarding what file system type is used on the USB stick? If I reformat the previous (old) stick, which choice is best?

From linux, any device manager would do (gparted, kde partition manager, gnome disks...): you open it, select the usb drive and it should say the filesystem used

For example, this is how my usb drive looks with the kde partition manager, where the usb drive uses the ntfs filesystem:


Windows's own disk manager can do the same if I remember correctly

If you only plan to use the usb drive on linux systems, I found ext4 to be quite fast. HOWEVER, if you plan to use the usb drive on both, windows and linux, ntfs should be fine, as windows can't read ext4. I'm unfamiliar with other filesystems, but those two work well, so that's what I recommend: ext4 if it's only for linux, ntfs if you want to keep compatibility with windows

1 Like

If You want to have it open and Your Stick isn't bigger than 32GB the FAT32 Fomat wouldn't be a bad Choice I think.

For that format, it also matters the size of the files saved. Also, the limit isn't 32 GB. FAT32 supports up to 2 TB in partition size, but individual files cannot be larger than 4 GB. So it mostly depends on what is the use case. For documents, images, and moderate-sized videos, it is a good option. For bigger movies, games or anything that takes more than 4 GB as an individual file, it won't work.

1 Like

Isn't this only with this ... how is it called ... FAT32+ Extension?

I don't have big enough drive that I'm willing to format to test, but, after searching around a bit more, some websites say that the limit is 2 TB, while others say, as you said, 32 GB... while referring at FAT32 as FAT32 without mentioning any extension. So there seems to be a bit of confusion between website writers here...

All I can confirm for sure is the 4 GB file size limit, as I myself got that error half-way through moving a 7 GB iso to a 8 GB usb with fat32, but not with ntfs

1 Like

Yes, me too. I had that in the Past when I were moving a big File on a FAT32 Stick.