Unlocking the screen is a bit slow on top in GNOME

Hi all,

Today i noticed that my screen is slow when unlocking (annimation ?), is this normal ? i already reinstalled the nvidia driver and that did not fix it. Any ideas ?

Video of GNOME: Zorin OS 16 lockscreen - YouTube
Video of Cinnamon: Zorin OS 16 Cinnamon Lockscreen - YouTube

Sorry for the bad quality, Xiaomi Poco M3 has a 48MP camera but well you see how terrible it is.

They both look fine to me. Which D.E. are you saying is slow?

Before unlocking you see the small bar going up

I also found this -> Lock screen post-unlock slide-up animation is very slow - only 1 or 2 frames visible (#2557) · Issues · GNOME / gnome-shell · GitLab

Ah, ok. GDM3 issue.
You may try reinstalling gdm... I don't have much hope that will help. But other than that... I am not sure.

So you have the same in GNOME ?

I would have to test it... I do not log into Gnome unless wearing full body armor and have three therapists on stand-by... So, I have not noticed it on mine.

EDIT:
I just went ahead and tested it. I logged into Gnome, then used the Lock Screen. It was fast and perfect. No artifacts. After testing twice, I realized the reason why...
I am not using GDM. I am using xscreenlocker and lightdm.

1 Like

I reinstalled gdm ?

sudo apt install gnome-session gdm3

Now i get the option Gnome, Cinnamon and Zorin Desktop at login ... sigh. I can't remove the Gnome one right ?

Is this... unrelated to the other thread...?

No to this one, i tried to reinstall gdm3 with that command and now i get 4 options to chose

Cinnamon
Cinnamon (software render)
Gnome
Zorin Desktop

Is there a way to delete that Gnome ?

Yes, and I had that too, actually.

The way that I did it was:

sudo apt remove zorin-os-desktop gnome gnome-shell

sudo apt install zorin-os-desktop

1 Like

Well i got thrown out of my desktop now, black screen and a blinking _

Rebooting and stuck on my acer logo...how to fix this ????

Cause i think the system files are removed now with that command

:expressionless:

Were you logged into Gnome instead of Cinnamon when you entered the command?

Arrow key down to the Enable Networking option in the recovery menu. Once enabled, back up to the recovery menu and arrow key down to drop to prompt.
Hit enter
then

sudo apt install -y zorin-os-desktop

1 Like

Nothing happens when pressing shift

Some say the esc key works... But as noted in the thread, it can be timing and persistence.

1 Like

Thanks that worked

1 Like

Awesome... I was getting worried. One problem leads to another... And I am sorry. I took it for granted that you would remove the desktop by being logged into one that was not currently running.
I will try to remember to make a note of that in future when giving users a tip on removals.

1 Like

No problem, what is the -y commando ?

-y tells apt to install any necessary dependencies along with the package.

1 Like

Well thanks again, the gnome in the list is removed. Thanks for the info, learned alot today haha.

Keep experimenting a bit in linux, want to learn a bit more :sweat_smile:.

When i got the black screen i thought...oh my i dont want to redo everything again haha.

I now know it's a gnome issue with the login screen

1 Like

Unlocking my workstation computer is slow for me as well. But I never blamed Zorin OS on that, because I know that the workstation is an old dual core machine, its slow, so its gonna take time to come out of the lock screen.