UNRESOLVED - Can't connect to internet

Hi there
I installed Zorin Lite on an old laptop and everything worked well. A short while ago I updated it and since then I have been unable to access the internet. I can see the machine on the router but regardless of the browser I can't get on to the net.... any ideas please? I am new to Linux so keep it simple!!!
Many thanks.

1 Like

Can you please roll back to the previous kernel and see if this allows your net to work?
To do so,
Follow the steps in this thread to get to Recovery menu.
Select the previous (lower number) kernel from Advanced Options for Zorin

1 Like

Hi there Aravisian.
Thanks for responding.
I tried rolling back to the previous kernel with no result… still not going onto the internet. I then tried the kernel before that and still no luck. I can see the laptop on my router so it is getting that far but unable to get beyond… any ideas?
Many thanks

Have you restarted the router and checked the router settings?
Otherwise, can you post the output of

lshw -c network


Hi Aravisian,
Hope you can view the attached file. I have restarted the router and the Zorin Laptop is not barred on the router. Many thanks for your help. Tim

Interesting, your driver should be included in the kernel. Maybe it needs to be flipped on. Can you try:

sudo modprobe iwl3945

Will do. Sorry -was away for a couple of weeks.

Hi Aracisian. Typed in as described but nothing happened??? Please see below.

Can you give me the output of

Thanks Frenchpress (I'm an Aeropress man myself!) hope this helps.

I found this.
It is also recommended to check and see if the physical switch for WiFi is not set to OFF position.

Wifi is definitely set to on and the pc is registering on the router so a wireless connection seems to be achieved but it isn't getting onto the internet. I have a virgin cable router and there are no restrictions on the connection....?

Do you have iwlwifi?
Let's find out... if this does not work, we will need to install it...

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

sudo modprobe -rfv iwlwifi

sudo modprobe -v iwlwifi

1 Like

Hope you understand all this!! Thanks.

Hi FrenchPress
Tried the fix's suggested in your link. No further on, I'm afraid. Here are the screenshots from them. I think I have included them all. Many thanks.

Yes, the module was present in the kernel and it is using the iwlwifi module now. You may try a restart and then testing your wifi and hope it works...

This might help?
I saw @Aravisian gave you an advice already.
You'd better follow his advise since he is way more experienced than myself.

This is debatable.

1 Like

Sorry Aravisian but no progress...

Can you try frenchpress's link above? You may prefer to replace vi with nano.