UNRESOLVED - Screen randomly loses resolution/colors

Hey guys,

I'm fairly new to Linux in general and someone gave me their old laptop so this is my 2nd Zorin install. It was password protected on Windows 10 so I just went ahead and did the full install after swapping out the HDD for a SSD.

My problem is it randomly loses resolution and the colors drastically change. Sometimes it goes back to normal after a few minutes but it always get corrected if I put it to sleep and wake it back up. Since I didn't get to use it with Windows, I'm not sure if this was a preexisting problem or not. It usually doesn't start doing it until 10 or 15 minutes of being on and sometimes it won't do it for hours of usage.

Are there any things I should be looking for? It's a decent laptop and is perfect for my uses but it's extremely frustrating. I tried to screenshot it last time it happened but the screenshot came out perfect so It may be a hardware issue.

Any ideas or suggestions would be great and I wouldn't be too upset if I end up having to replace the screen if that is the likely culprit.

I did clean out all of the dust and cat hair it contained and it barely runs warm so I'm not thinking it's a heating issue.

Here are the specs of the laptop:

Screenshot from 2021-10-12 22-40-30

It's an HP Elitebook 750 G1.


1 Like

This is one informative O.P.

Are you logging in on Wayland?

I agree, it really is a breath of fresh air, to see this!

My question will be, has the OP plugged in an external monitor or TV, to see if it exhibits the same issues? Because if it does, its obviously the computer. But if doesn't do this, then its the laptop screen for sure.

1 Like

I tried what I could before I ran out of knowledge.

I have not tried Wayland. I will give it a shot and report back on what happens.

I haven't tried an exterior monitor but I will also give that a shot.

I did forget to mention that simply switching resolution will sometimes cause it to clear up and other times it will clear it up for a few seconds then go right back to weirdness.

I used to enjoy DOS back in the day but haven't built a computer since the excitement of Windows ME. I did recently build a Ryzen desktop to edit 4k video on and it kind of sparked my enthusiasm again which led me into the Linux world. It has been fun and brought two otherwise useless laptops back to life but I'm not sure I'm ready to take the plunge on the desktop. Maybe in a few more months or so.

Thanks for the ideas.

...Actually, I asked in order to ensure that you weren't. :wink: You can try it, but even if it works, a bunch of apps won't work...

Have you checked your screen refresh rate?

I will try to get a screenshot of the options it gives me. It shows 3 of the same resolutions settings which I though was a little odd and it shows 60hz and 59.??hz. I have tried combinations of all the settings. I can add when I dropped the resolution down it seemed to go longer without doing it but it's so random that I can't say that is what helped with certainty.

I did try to find an alternate driver but couldn't find anything in the additional drivers area nor a good tutorial on how to add drivers.


I wonder if you need the HWE?

sudo apt install linux-headers-generic-hwe-20.04 linux-image-generic-hwe-20.04 linux-modules-extra-5.11.0-37-generic

It says it's already the newest version.

That means you already have the latest kernel installed.

Type uname -a

Post results here...

Is that even possible in Zorin OS 16 ? Because i never got that option.

Yes, it shows as Zorin Desktop on Wayland.

When i used zorin i had not that option at login screen. Weird.

Linux james-HP-EliteBook-750-G1 5.11.0-37-generic #41~20.04.2-Ubuntu SMP Fri Sep 24 09:06:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Does this look correct?

From a kernel standpoint, this looks very correct! @Aravisian What do you think? This look correct to you? It does to me. :+1:

Yes, that is the current latest Kernel on Zorin OS. But clearly, something is not working right. It is possible that the 5.11 kernel has some Intel regression.

I wonder if the 5.8 kernel might work.
If you want, you can test it:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63 linux-modules-extra-5.4.0-63-generic linux-image-5.8.0-63

Once installed, reboot, then tap the esc key repeatedly beginning at the Motherboard Splash Screen to pull up the Grub Menu with Recovery- Advanced Options for Zorin > Then arrow key down to the 5.8.0-63 kernel and select that to boot up from.

Ok. Before I waste too much of your time, do you think it's a software issue? If it's hardware I can buy the screen and try it.

I wanted to get screenshots of the display settings and it offered 40hz as an option. Today is the first time I've seen that.

Screenshot from 2021-10-13 11-14-22

Also, while typing this up, it did the weird resolution thing. I swapped it to one of the other 1360x768 options and it came back on fine.

I appreciate the help. It's a very annoying problem to be having on such a nice laptop. It makes me hesitant to use it for online classes as you need to exit out of the desktop to clear it up.

Thanks again.


Also, I got this...

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-modules-5.8.0-63
E: Couldn't find any package by glob 'linux-modules-5.8.0-63'
E: Unable to locate package linux-modules-extra-5.4.0-63-generic
E: Couldn't find any package by glob 'linux-modules-extra-5.4.0-63-generic'
E: Unable to locate package linux-image-5.8.0-63
E: Couldn't find any package by glob 'linux-image-5.8.0-63'

I have no idea.

But I prefer to exhaust software possibilities as much as we can, since those solutions do not require rushing out and buying something which may or may not work.
I am a mechanic by trade- so yuo can imagine, I have a very low opinion of the "Throw new parts at a problem until the problem goes away" approach.
Proper Diagnostics are the Proper approach.
Sadly, I am better with cars, then I am computers.

Incidentally... Have you upgraded since installing Zorin OS? Just... in case...

sudo apt update && sudo apt full-upgrade

That is very odd. :expressionless:
I checked the packages in my terminal prior to submitting that post.

Can you open Software & Updates from the app menu and under the section Download from - Check if you are on Main Server.

It was set to "Main Server for United States." I changed it to Main Server.

It is downloading 13 updates from the sudo apt command now.

What kind of cars do you work on?

Classic car mechanic and Restoration. I do, however, begrudgingly work on the New Junk in between :stuck_out_tongue:

I enjoy the many months that can stretch where we are too busy to take in anything newer than 1970's vehicles.

Since Covid... It has been... interesting...