Zorin Forum

UNRESOLVED - Windows + Linux multiboot system boots directly to Windows without showing the GRUB

Can I ask a question? I don't know if it is related to the topic though...
One time I tried to multiboot,
Windows+Ubuntu(21.10)+Zorin Lite.
I installed Windows first, the Ubuntu and then Zorin Lite.
The problem was, after I created all the partitions and finished install Zorin Lite, I restarted but the GRUB never appeared. Instead it booted straight into Windows. I had to delete the Linux partitions (after creating a backup of the home partition) and cleared the EFI of the linux bootloaders (using CMD). I installed Ubuntu again afterwards but kept it up to dual boot. Do you know went wrong? What should I have done?

The short answer is that Windows recognizes itself as Default within the Bootloader and of course, wants only itself used and itself First.
You can read about suggested solutions here:

I installed Windows first...and then other Operating Systems.
Unfortunately, the BIOS is probably outdated and the only options I get in Boot Order are:
External Disk
Internal Hard Drive
Network Boot
and another thing that I don't remember but is completely unrelated.

I had similar issue several years ago after setting up dual boot with Windows 8.1 and Ubuntu. The successful option for me (provided by a helpful member of the Ubuntu Forum) was the "Set up trusted EFI file" option from the BIOS - mentioned some way down the responses on the link posted by Aravisian. That enabled Grub to be "restored" and then pushed up the boot order. I've used that ever since on dual boots when I've encountered this issue. I have never gone as far as triple-booting so don't know if that would be the solution but suspect that the principle would be the same.

1 Like

Thanks for the suggestion, I will look at it.

Sadly, the trusted EFI file option does not show up even when I enable secure boot.

Marked solution. 189

@carmar, it would be better to not mark any solution for this topic yet...Since none of them worked...I will edit the title and unmark the solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.