Updating my system as usual, but some updates are being kept back

Sorry about that.
Right click and Open In Text Editor.

Now we're in business

1 Like

I am leaving to go to the store- but you have the above posts to reference.

1 Like

Thank you for all your help so far, no rush at all on my end.

After saving the sources.list edits with all "Cr" removed, I reloaded the software & updates, and tried updating through terminal again.

Apparently no luck yet.

Is your system running normally?
Early in this thread, we noted you had removed libqtgui5.
I wonder if you had installed, then removed a package that needed the above held packages, which are now not upgrading due to the missing package that depended on them.
You may try

sudo apt remove --purge libqt5gui5 libgl1-mesa-dri:i386 libglapi-mesa:i386 libglx-mesa0:i386 && sudo apt install libqt5gui5 libgl1-mesa-dri:i386 libglapi-mesa:i386 libglx-mesa0:i386

I have never tinkered with these packages, only installed a long time ago and never worried about it since.

An error as always. It did, however, uninstall my steam lol.

I would reinstall steam

sudo apt install --reinstall steam

Then run the updater... if you see an error for the i386 items, I would then remove them:

sudo apt remove libgl1-mesa-dri:i386 libglapi-mesa:i386 libglx-mesa0:i386

and test the system without them.

It looks like the 32bit i386 packages are trying to replace the 64 bit packages - which is why APT is protecting your system by holding them back.

Can't, held packages.

After this, I have only one package not upgraded

What a mess

sudo apt --fix-broken install

done, 1 not upgraded still

sudo apt install -y steam


This does not make any sense...
You are certain that all four boxes are checked on your Software & Updates first tab?

Once that is checked, go to the Updates tab and check "Subscribed to" - Set this to All Updates.

When you close it, it may want to reload... allow it.
In terminal:

sudo apt update && sudo apt instal -f

sudo dpkg --configure -a

sudo apt update && sudo apt full-upgrade

OK so when I say "All updates" it doesn't do it, it just goes back to "Custom"

Completely certain.

I wonder if Synaptic may help...
If you do not have it installed:

sudo apt install synaptic

Launch Synaptic, then on the bottom left, select "Custom Filters" and then in the upper portion of the pane, select "Broken"
If any are listed, try to correct them using Synaptic.

If nothing is listed, under "Status", you can check "Installed (Manual)" and "Installed (autoremovable" lists and see if any package has been installed that was removed that left configuration files that are causing a dependency conflict.

1 Like

It told me today as I ran the update command that I had 4 additional versions, which I opened up here. Is one of these the key to finishing the upgrade?

Oh shoot that was easy! I installed synaptic and it helped me immediately to upgrade the mesa vulkan packages.

Thank you Aravisian. You are, as always, a wizard.


I think Synaptic was the wizard, this time. I was spinning my wheels for fifty posts.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.