Updating my system as usual, but some updates are being kept back

I am having trouble finishing some updates. As you can see, the mesa vulkan drivers are giving me some trouble. I tried doing a specific "sudo apt upgrade [the drivers]" but it didn't work, and neither did "sudo apt dist-upgrade."

Am I doing something wrong? thank you.

It looks like only the 32bit drivers are held.
What is the terminal output of:

dpkg --print-foreign-architectures

Output is:

Ok, please check in Software & Updates that you are set to Main Server
And that the following Sources are checked (Four of them):

Close out Software & Updates - refresh if it asks...

Open terminal and run:

sudo apt clean && sudo apt autoremove

sudo apt update && sudo apt full-upgrade

relay the results

The results.

It seems nothing has changed.

Ok can you try

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Same exact output

The full-upgrade should have handled that...
Can you try

sudo apt dist-upgrade


sudo apt --with-new-pkgs upgrade

If still no good, try

sudo apt install -y libgl1-mesa-dri:i386 libglapi-mesa:i386 libglx-mesa0:i386

Note Any Warnings or Replacements - it may be holding those packages back for a good reason. Check the Terminal Output.

Same output

same output

The output on this image.

In our repositories:

libqt5gui5/focal-updates,focal-security,focal-updates,now 5.12.8+dfsg-0ubuntu2.1 amd64 [installed,automatic]
  Qt 5 GUI module

Try installing it:

sudo apt install -y libqt5gui5 && sudo apt upgrade

I just noticed that in this image it shows cr.archive.ubuntu

You are not on Main Server.

I made sure I was on Main Server as soon as you mentioned it.

Sometimes, I see this happen, where it doesn't change, even though software & updates says it did.
The cr.archive.ubuntu makes me think this is the case.
Can you check the sources list?

sudo nano /etc/apt/sources.list

Does this have anything to do with these repositories? I noticed right now that it includes "Unsupported updates" which looks rather promising for our purposes..

Pardon the tiny font, just wanted to fit it all in one picture

Great - ok, you can see that some of the entries say archive.ubuntu and some say cr.archive.ubuntu
You can use GUI if it is easier:

sudo -i


Navigate to "other locations > Computer" then, /etc/apt and right click on sources.list and open in Text Editor - then, remove the "cr" on each entry that has it.

Cr supposed to be on the title of these files?

No, elevate up one directory and open sources.list

Ok that opens Software & Updates GUI directly

Still no Cr visible