Updating to kernel version 5.13

Now running 5.13.0-25...came down with the latest update. Seems stable. Now I have to try and break things. :smiley: I'm not expecting issues (usually don't have any on these updates) but you never know.

1 Like

Wow! That's great....I received the update too.

1 Like

I hope it keeps you bubbly happy like it does me. :purple_heart: :blush:

Ooooooo, I just noticed it says your volunteer tech support now, that means I get to ask you lost of questions! Just kidding, I made you think though didn't I? HAHA. Hope you like the position.

Just remember, its not easy, try not to take that tag too seriously, don't let it make you feel completely obligated. Take things at your own pace, and you might just do better then I.

Alright, start your engines, 5.13 kernel loaded into Mr. Fusion, cause once I get this baby to 88 miles per hour, your gonna see some serious shikernels popping out the back of the muffler.

Honk honk, coming through. Weeeeeeeeeeeeeeeeee :grin:

1 Like

I wanted the title to be "Volunteer" instead of "Volunteer Tech Support" but there seems to be no way to do that.

1 Like

I noticed a major improvement in boot speed since 5.13. Is it only me?

This is strange!

After two kernel updates now, my system continues to use the older 5.11.41 kernel!

I just restarted, and then ran both screenfetch and a uname -a, and they both confirm I am running on kernel 5.11.41.

Now I have to try and figure out how to force my system to use the updated 5.13 kernel, cause I don't remember how to do that. Usually when my system gets a kernel update, it switches to it, but it hasn't been doing that lately for some reason.

@AZorin @zorink I am unable to get GRUB to list any newer kernel beyond 5.11.41. And thus I am unable to use the 5.13 kernel. Please read the following posts below, to get updates on everything I tried to fix this to no avail.

Check if you have an apt hold

apt-mark showhold

Check that the newer kernel is installed:

dpkg --list | grep linux-image

Check grub:

sudo nano /etc/default/grub

Ensure that grub default is set to 0: GRUB_DEFAULT=0

You can boot from advanced options for Zorin to choose which kernel to boot from.

I confirmed 5.13 is installed by checking list of installed kernels. When I ran apt hold command, it listed nothing. Grub options are set correctly.

I rebooted into grub and I took this snapshot real quick to post to the forum, while I reboot into the system again.

Just in case, try

sudo apt update && sudo apt full-upgrade

Then remove the 5.11.0-40 kernel.
Once done

sudo update-grub

Reboot and test...

I ran those commands above, and here is where I am at now, with this situation.

List of installed kernels...

Screenshot from 2022-01-19 13-59-34

Synaptic Package Manager confirmation...

After running the update and upgrade commands, the GRUB menu is still only showing options for the 5.11 kernel, no sense taking a new pic since its exactly the same as before.

Running your command for listing installed kernels...

Here are the GRUB options as they are now...

At the end of the day, the GRUB menu refuses to list the new installed kernel, I don't know what is going on. I don't know if its something I am doing wrong, or there is something wrong with the OS.

uname -a

Did you run

sudo update-grub


I swear that I had run it, but maybe it didn't take? So I ran it again, and I got this...

Now, I just need to reboot into GRUB and see what options there are, so I will restart again and let you know, for now I posted what it did when I ran the GRUB update command.

1 Like

It's the same, no change. God I hate computers. There's just no fixing this is there?

See, no change..

This is a strange one...
Can you try

sudo apt install --reinstall linux-image-generic linux-image

sudo update-initramfs -u -k $(uname -r)

sudo update-grub


After running first command, it generated a huge list of linux image stuff. And ended with this...

E: Package 'linux-image' has no installation candidate

When I ran the next command, it took a bit to complete, and it ended with this...

update-initramfs: Generating /boot/initrd.img-5.11.0-41-generic

Then ran the GRUB update...

OK, time for me to reboot and see whats happening now, I'll get back to you quickly by phone like last times for that.

It is still deferring to the 5.11

sudo apt clean && sudo apt autoremove

Same problem, only 5.11.40 and 5.11.41 in the list, no change.

Ok I'll run those commands once I get booted in

OK I did it, seemed there was something to remove. I assume that I should be running the update GRUB command again, so I will run that too, and then I will reboot and let you know.

K, ran the Grub update command, that part didn't look like any change in that process. Now I am going to reboot and let you know.

Still the same. I don't understand any of this. I'm frankly at the point of giving up. This OS won't straighten up and fly right. I'll never see another kernel update ever again at this point.

Treker, I understand your frustration.
I routinely deal with that same frustration across countless threads trying to figure out why something is behaving oddly.

At the moment, I am stumped as to why the 5.13 kernel is not being recognized. In fact, it is the first time I have ever seen that happen.
Please try to handle frustration in a more productive way...