Zorin Forum

Updating to kernel version 5.13

Just in case, try

sudo apt update && sudo apt full-upgrade

anyway.
Then remove the 5.11.0-40 kernel.
Once done

sudo update-grub

Reboot and test...

I ran those commands above, and here is where I am at now, with this situation.

List of installed kernels...

Screenshot from 2022-01-19 13-59-34

Synaptic Package Manager confirmation...

After running the update and upgrade commands, the GRUB menu is still only showing options for the 5.11 kernel, no sense taking a new pic since its exactly the same as before.

Running your command for listing installed kernels...

Here are the GRUB options as they are now...

At the end of the day, the GRUB menu refuses to list the new installed kernel, I don't know what is going on. I don't know if its something I am doing wrong, or there is something wrong with the OS.

uname -a


Did you run

sudo update-grub

?

I swear that I had run it, but maybe it didn't take? So I ran it again, and I got this...

Now, I just need to reboot into GRUB and see what options there are, so I will restart again and let you know, for now I posted what it did when I ran the GRUB update command.

1 Like

It's the same, no change. God I hate computers. There's just no fixing this is there?

See, no change..

This is a strange one...
Can you try

sudo apt install --reinstall linux-image-generic linux-image

sudo update-initramfs -u -k $(uname -r)

sudo update-grub

Reboot...

After running first command, it generated a huge list of linux image stuff. And ended with this...

E: Package 'linux-image' has no installation candidate

When I ran the next command, it took a bit to complete, and it ended with this...

update-initramfs: Generating /boot/initrd.img-5.11.0-41-generic

Then ran the GRUB update...

OK, time for me to reboot and see whats happening now, I'll get back to you quickly by phone like last times for that.

It is still deferring to the 5.11

sudo apt clean && sudo apt autoremove

Same problem, only 5.11.40 and 5.11.41 in the list, no change.

Ok I'll run those commands once I get booted in

OK I did it, seemed there was something to remove. I assume that I should be running the update GRUB command again, so I will run that too, and then I will reboot and let you know.

K, ran the Grub update command, that part didn't look like any change in that process. Now I am going to reboot and let you know.

Still the same. I don't understand any of this. I'm frankly at the point of giving up. This OS won't straighten up and fly right. I'll never see another kernel update ever again at this point.

Treker, I understand your frustration.
I routinely deal with that same frustration across countless threads trying to figure out why something is behaving oddly.

At the moment, I am stumped as to why the 5.13 kernel is not being recognized. In fact, it is the first time I have ever seen that happen.
Please try to handle frustration in a more productive way...

Thats what I am doing right now...

I didn't have the time nor patience anymore to deal with it, my frustration was at a MAX. So I gave up, and went onto other tasks. Which I am still doing BTW.

Also, I can't keep doing endless restarts expecting different results. Eventually I just have to call it and move on, which is what I am doing now.

I think this is a problem for the Zorin brothers honestly.

Keep in mind, I also entertained the theory that maybe GRUB was getting updated for the other drive, the XFCE installation. But I checked the advanced options for Zorin OS 16 LITE, and there were no updates to it, only two kernel options listed.

This is cause I wasn't on XFCE long to allow a full list of kernels to generate. So point is, I confirmed, that GRUB was not being updated for the wrong drive. GRUB was indeed being updated for the right drive, for the right installation Zorin OS 16 Gnome.

Since there is no resolution at this time, like I said, I am moving on, I got other things to do. And I also need my computer running for other tasks, so constant rebooting into GRUB won't help me for other tasks.

I do provide you thanks for taking time out of your day, and trying to help me. But as with things in Linux, not all problems have solutions. Thats just the reality with Linux.


2 Likes

Treker, do not worry about restarting... but when you have time, can you please open terminal and run

sudo apt update && apt list -u

On mine, it shows that a new 5.13.0-27 is now being offered.

I ran the command, and this was the result...

I don't know what I am supposed to be looking for. But if I understand this correctly, its telling me that one application can be updated, and that is Google Chrome. Which I don't see what that has anything to do with my kernel issue. But anyways, those are the results.


I do not know why we are seeing Different Available Updates. I saw the 5.13.0-27 pop up within minutes of having not seen it, which implies it had just rolled down the pipe.
It may be that it just needs more time to work its way through the servers to you.

Other than trying sudo update-initramfs -u - I am as stumped as you are as to why the system is recognizing an installed kernel but will not see it when updating grub.

Now I am logging off the forum for a Very Much Needed Break.

Marked Solution. 299

1 Like

@StarTreker As you have installed Zorin OS 16 Lite alongside Zorin OS 16 Pro, the boot loader (GRUB) is now pointing to the configuration on the Lite partition rather than the Pro partition. The update-grub command on your Zorin OS Pro partition is having no effect as GRUB is pointing to the Lite partition instead.
To resolve the issue you will need to boot into Zorin OS Lite and run this in the Terminal:

sudo update-grub

If this doesn't resolve the issue, you can try repairing the boot loader by following this guide:

For Pro support, we would recommend you to use the Zorin Installation Support form on our website as it can often take us some time to get on top of our forum mentions.

2 Likes

@zorink

I just wanted to quickly update and let you know that it worked!

Screenfetch...

I am also aware of the new version of Zorin OS version 16.1, I appear to have been updated to it as well...

Thank you so much for helping me Zorink, it is much appreciated, as I really needed this fixed! We haven't heard from Azorin since September I think, is he OK, please let the forum know. Hope you both are doing well.


NOTE: For those that think I have returned, please don't get any ideas. I only felt it prudent to return to the forum once I had a chance to implement the instruction given by ZorinK to fix my computer. My decision on no longer participation stands.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.