Upgrade from 16.3 to 17 Failed (Interrupted)

The update from Zorin OS 16.3 to 17 Core interrupted during the Install New Apps step.

It seems like some package (v4l2loopback) prevented apt from continuing to upgrade. Now I rebooted and entered Zorin OS 17, some gnome extensions are lost, tons of packages can be autoremoved by apt.
Also, apt returned this while running sudo apt update:

/usr/share/squid-deb-proxy-client/apt-avahi-discover:6: DeprecationWarning: The asyncore module is deprecated and will be removed in Python 3.12. The recommended replacement is asyncio
  import asyncore

The system seemed not fully upgraded and not cleaned, should I re-install it?

I can't put the log here maybe it's too long, the forum returned 500 Error.

Can you list the autoremoveable items and the missing extensions? This may allow us to see whether they are normal packages to be removed or if something is messed up.

The v4l2loopback package requires DKMS, so I can see how it might be troublesome.

Eh… sorry it was too late yesterday and I didn’t take any screenshots. I tried to solve them and find how the problem caused.

I noticed that some important packages like cpp can’t be upgraded successfully or just waiting to be auto removed because It can only find the 20.04 version of gcc-11-base while cpp-11 needed version is for 22.04. I can find the 22.04 version via apt search but it can’t locate the package so I used gcc-11-base:i386 instead and cpp can be reinstalled successfully (notice that apt couldn’t automatically use gcc-11-base:i386 instead of gcc-11-base, and caused the error that cpp can’t upgrade)


(I interrupted apt because some core packages will be removed with cpp)

Usually there may be focal repositories left but I checked both sources.list and sources.list.d, they are all in jammy, I don’t know why apt can’t find the 22.04 version of gcc-11-base. But installing gcc-11-base:i386 could actually solve the problem.

Another problem with ppa repositories is that when the upgrader simulates apt, it can’t replace the word “focal” with “jammy” when proxy url is used to replace the default ppa.launchpad.net, which prevented the upgrader to check update for zorin os 17.
(Please check this link)

Oh, I noticed that all my installed ppa repositories is disabled after the upgrade to zorin 17. I could uncomment to enable them and they worked properly. I wonder why this is happened. I searched the forum and found that this problem may be an exceptional case, but this can be re-produced on my testing vm that used proxy urls to replace the default ppa url.

About other autoremovable packages, they’re just unnecessary old packages that should be removed during the cleaning in the Zorin Upgrader, they’re all okay.

The lost extensions, they’re just incompatible with GNOME 43, I used a third-party extension manager updated them and they worked properly.

About v4l2loopback, it actually caused an error while updating initramfs. It’s about the dkms and interrupted the upgrade, I didn’t take screenshots yesterday but it now works properly after uninstalling and re-installing.

Thanks again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.