Upgrade to 17 Pro failed & package manager broken

Hi All, I tried running the upgrade from 16.3 Pro to 17 Pro after running all updates in software updater. Unfortunately, it failed [log below] and now it seems that package manager is broken. I tried sudo apt-get install -f but that also failed. Software Updater is now giving an error that not all updates can be installed and offers Partial Upgrade, which results in a loop to the same prompt, or Continue which presents this error It is impossible to install or remove any software. Please use the package manager "Synaptic" or run "sudo apt-get install -f" in a terminal to fix this issue at first.

I'm not sure how to unwind or repair the failed upgrade and I'd rather not wipe and reinstall if possible. Thanks!

last few lines of zorin_os_upgrader log

dpkg: error processing package libwebkit2gtk-4.0-37:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libfreexl1:amd64 (1.0.6-1) ...
dpkg: dependency problems prevent configuration of libmutter-10-0:amd64:
 libmutter-10-0:amd64 depends on libgl1; however:
  Package libgl1:amd64 is not configured yet.

dpkg: error processing package libmutter-10-0:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libnsl-dev:amd64 (1.3.0-2build2) ...
Setting up sensible-utils (0.0.17) ...
Setting up libdv4:amd64 (1.0.0-14build1) ...
Setting up libdv4:i386 (1.0.0-14build1) ...
Setting up ocl-icd-libopencl1:amd64 (2.2.14-3) ...
Setting up ocl-icd-libopencl1:i386 (2.2.14-3) ...
Setting up libasyncns0:amd64 (0.8-6build2) ...
Setting up libasyncns0:i386 (0.8-6build2) ...
Setting up libexif-doc (0.6.24-1build1) ...
Setting up libxshmfence1:amd64 (1.3-1build4) ...
Setting up libxshmfence1:i386 (1.3-1build4) ...
Setting up libusbmuxd6:amd64 (2.0.2-3build2) ...
dpkg: dependency problems prevent configuration of libopencv-viz4.5d:amd64:
 libopencv-viz4.5d:amd64 depends on libvtk9.1 (>= 9.1.0+really9.1.0+dfsg2); however:
  Package libvtk9.1:amd64 is not configured yet.

dpkg: error processing package libopencv-viz4.5d:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopencv-highgui-dev:amd64:
 libopencv-highgui-dev:amd64 depends on libavcodec-dev; however:
  Package libavcodec-dev:amd64 is not configured yet.
 libopencv-highgui-dev:amd64 depends on libavformat-dev; however:
  Package libavformat-dev:amd64 is not configured yet.
 libopencv-highgui-dev:amd64 depends on libdc1394-dev; however:
  Package libdc1394-dev:amd64 is not installed.
 libopencv-highgui-dev:amd64 depends on libopencv-videoio-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Version of libopencv-videoio-dev:amd64 on system is 4.2.0+dfsg-5.
 libopencv-highgui-dev:amd64 depends on libswscale-dev; however:
  Package libswscale-dev:amd64 is not configured yet.

dpkg: error processing package libopencv-highgui-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libbluetooth3:amd64 (5.64-0ubuntu1.1) ...
dpkg: dependency problems prevent configuration of libavfilter7:amd64:
 libavfilter7:amd64 depends on libavcodec58 (= 7:4.4.2-0ubuntu0.22.04.1); however:
  Version of libavcodec58:amd64 on system is 7:4.2.7-0ubuntu0.1.
 libavfilter7:amd64 depends on libavformat58 (= 7:4.4.2-0ubuntu0.22.04.1); however:
  Package libavformat58:amd64 is not configured yet.
 libavfilter7:amd64 depends on libavutil56 (= 7:4.4.2-0ubuntu0.22.04.1); however:
  Version of libavutil56:amd64 on system is 7:4.2.7-0ubuntu0.1.
 libavfilter7:amd64 depends on libpostproc55 (= 7:4.4.2-0ubuntu0.22.04.1); however:
  Package libpostproc55:amd64 is not configured yet.
 libavfilter7:amd64 depends on libswresample3 (= 7:4.4.2-0ubuntu0.22.04.1); however:
  Version of libswresample3:amd64 on system is 7:4.2.7-0ubuntu0.1.

dpkg: error processing package libavfilter7:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gdm3:
 gdm3 depends on gnome-shell (>= 3.37.90); however:
  Package gnome-shell is not configured yet.

dpkg: error processing package gdm3 (--configure):
 dependency problems - leaving unconfigured
Setting up libcrypt-dev:amd64 (1:4.4.27-1) ...
Setting up libwavpack1:amd64 (5.4.0-1build2) ...
Setting up libwavpack1:i386 (5.4.0-1build2) ...
dpkg: dependency problems prevent configuration of libopencv-features2d-dev:amd64:
 libopencv-features2d-dev:amd64 depends on libopencv-flann-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Package libopencv-flann-dev:amd64 is not configured yet.
 libopencv-features2d-dev:amd64 depends on libopencv-highgui-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Package libopencv-highgui-dev:amd64 is not configured yet.
 libopencv-features2d-dev:amd64 depends on libopencv-ml-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Package libopencv-ml-dev:amd64 is not configured yet.

dpkg: error processing package libopencv-features2d-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libasan8:amd64 (12.3.0-1ubuntu1~22.04) ...
Setting up libfyba0:amd64 (4.1.1-7) ...
Setting up libspeexdsp1:amd64 (1.2~rc1.2-1.1ubuntu3) ...
Setting up libasound2:amd64 (1.2.6.1-1ubuntu1) ...
Setting up libasound2:i386 (1.2.6.1-1ubuntu1) ...
Setting up libnsl2:i386 (1.3.0-2build2) ...
Setting up libkmlbase1:amd64 (1.3.0-9) ...
Setting up libraw1394-tools (2.1.2-2build2) ...
Setting up libblosc1:amd64 (1.21.1+ds2-2) ...
Setting up libnl-3-200:amd64 (3.5.0-0.1) ...
Setting up libmpdec3:amd64 (2.5.1-2build2) ...
Setting up bogofilter-common (1.2.5-1build2) ...
Installing new version of config file /etc/bogofilter.cf ...
dpkg: dependency problems prevent configuration of gnome-shell-extension-zorin-dash:
 gnome-shell-extension-zorin-dash depends on gnome-shell (<< 45~); however:
  Package gnome-shell is not configured yet.
 gnome-shell-extension-zorin-dash depends on gnome-shell (>= 40); however:
  Package gnome-shell is not configured yet.

dpkg: error processing package gnome-shell-extension-zorin-dash (--configure):
 dependency problems - leaving unconfigured
Setting up libpsm2-2 (11.2.185-1) ...
Setting up libxcvt0:amd64 (0.1.1-3) ...
dpkg: dependency problems prevent configuration of remmina-plugin-vnc:amd64:
 remmina-plugin-vnc:amd64 depends on remmina (= 1.4.25+dfsg-1ubuntu0.1+zorin1); however:
  Package remmina is not configured yet.

dpkg: error processing package remmina-plugin-vnc:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libopencv-core4.5d:amd64 (4.5.4+dfsg-9ubuntu4) ...
Setting up openmpi-common (4.1.2-2ubuntu1) ...
Setting up gnome-session-common (42.0-1ubuntu2) ...
Setting up hunspell-en-us (1:2020.12.07-2) ...
Setting up libuno-salhelpergcc3-3 (4:7.6.4-0ubuntu0.22.04.1~lo1) ...
Setting up libtasn1-6:amd64 (4.18.0-4build1) ...
Setting up libtasn1-6:i386 (4.18.0-4build1) ...
Setting up libpam-systemd:amd64 (249.11-0ubuntu3.12) ...
Setting up fonts-crosextra-caladea (20130214-2.1) ...
Setting up libmd4c0:amd64 (0.4.8-1) ...
Setting up libc6-i386 (2.35-0ubuntu3.6) ...
Setting up libv4l2rds0:amd64 (1.22.1-2build1) ...
dpkg: dependency problems prevent configuration of libopencv-videostab-dev:amd64:
 libopencv-videostab-dev:amd64 depends on libopencv-photo-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Package libopencv-photo-dev:amd64 is not configured yet.
 libopencv-videostab-dev:amd64 depends on libopencv-video-dev (= 4.5.4+dfsg-9ubuntu4); however:
  Package libopencv-video-dev:amd64 is not configured yet.

dpkg: error processing package libopencv-videostab-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libzimg2:amd64 (3.0.3+ds1-1) ...
Setting up libopenjp2-7:amd64 (2.4.0-6) ...
Setting up libopenjp2-7:i386 (2.4.0-6) ...
Setting up git-man (1:2.34.1-1ubuntu1.10) ...
dpkg: dependency problems prevent configuration of libglx-dev:amd64:
 libglx-dev:amd64 depends on libglx0 (= 1.4.0-1); however:
  Version of libglx0:amd64 on system is 1.3.2-1~ubuntu0.20.04.2.

dpkg: error processing package libglx-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libthai-data (0.1.29-1build1) ...
Setting up xorg-sgml-doctools (1:1.11-1.1) ...
Setting up netbase (6.3) ...
Installing new version of config file /etc/services ...
dpkg: dependency problems prevent configuration of virtualbox:
 virtualbox depends on libgl1; however:
  Package libgl1:amd64 is not configured yet.

dpkg: error processing package virtualbox (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Processing triggers for dictionaries-common (1.28.14) ...
Processing triggers for libc-bin (2.35-0ubuntu3.6) ...
 }
[INSTALLING UPGRADES:Apt > Committing Upgrades] Failed
[INSTALLING UPGRADES] Failed
Upgrade Failed

output of sudo apt-get install -f

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dvd+rw-tools gir1.2-gnomebluetooth-1.0 libamtk-5-0 libamtk-5-common libaom0
  libaom0:i386 libboost-date-time1.71.0 libboost-filesystem1.71.0
  libboost-iostreams1.71.0 libboost-locale1.71.0 libboost-thread1.71.0
  libcaf-openmpi-3 libcbor0.6 libcoarrays-openmpi-dev libcodec2-0.9
  libcodec2-0.9:i386 libdc1394-22-dev libextutils-pkgconfig-perl
  libgphoto2-l10n libhogweed5:i386 libibverbs-dev libicu66:i386 libicu67
  libmozjs-78-0 libnettle7:i386 libnl-3-dev libnl-route-3-dev libopenmpi-dev
  libpcre2-posix2 libpgm-5.2-0 libphonenumber7 libpython3.8-dev libraw19
  libsasl2-modules:i386 libssl1.1:i386 libtepl-4-0 libtracker-control-2.0-0
  libtracker-miner-2.0-0 libvpx6 libvpx6:i386 libwebp6:i386
  libwhoopsie-preferences0 libwhoopsie0 libwrap0:i386 libx264-155:i386
  libx265-179 libx265-179:i386 lz4 openmpi-bin openmpi-common
  python3-packaging python3-pyparsing python3.8-dev whoopsie-preferences
  x11proto-input-dev x11proto-randr-dev x11proto-xinerama-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  cups-server-common dleyna-renderer dleyna-server fonts-urw-base35
  gedit-common libavcodec58 libavcodec58:i386 libavutil-dev libavutil56
  libavutil56:i386 libayatana-appindicator3-1 libbabl-0.1-0 libcodec2-1.0
  libdc1394-dev libegl1 libgegl-0.4-0 libgegl-common libgl1-amber-dri
  libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386
  libglvnd0 libglvnd0:i386 libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386
  libgnome-autoar-0-0 libgs9 libgs9-common libgssdp-1.2-0 libgupnp-1.2-1
  libgupnp-av-1.0-3 libgupnp-dlna-2.0-4 libnautilus-extension1a
  libopencv-core-dev libopencv-imgcodecs-dev libopencv-imgproc-dev
  libopencv-videoio-dev libosmesa6 libosmesa6:i386 libraw20
  librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2
  librygel-server-2.6-2 libswresample-dev libswresample3 libswresample3:i386
  libx264-163 libx264-163:i386 libx265-199:i386 tracker
Suggested packages:
  fonts-texgyre libcuda1 libnvcuvid1 libnvidia-encode1 libcuda1:i386
  libnvcuvid1:i386 libnvidia-encode1:i386 graphviz
Recommended packages:
  libgl1-amber-dri:i386
The following packages will be REMOVED:
  libappindicator3-1 libavresample-dev libavresample4 libgupnp-av-1.0-2
  libgupnp-dlna-2.0-3 libopencv-ts-dev
The following NEW packages will be installed:
  libayatana-appindicator3-1 libcodec2-1.0 libdc1394-dev libgl1-amber-dri
  libgupnp-1.2-1 libgupnp-av-1.0-3 libgupnp-dlna-2.0-4 libraw20 libx264-163
  libx264-163:i386 libx265-199:i386
The following packages will be upgraded:
  cups-server-common dleyna-renderer dleyna-server fonts-urw-base35
  gedit-common libavcodec58 libavcodec58:i386 libavutil-dev libavutil56
  libavutil56:i386 libbabl-0.1-0 libegl1 libgegl-0.4-0 libgegl-common
  libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386
  libglvnd0 libglvnd0:i386 libglx-mesa0 libglx-mesa0:i386 libglx0 libglx0:i386
  libgnome-autoar-0-0 libgs9 libgs9-common libgssdp-1.2-0
  libnautilus-extension1a libopencv-core-dev libopencv-imgcodecs-dev
  libopencv-imgproc-dev libopencv-videoio-dev libosmesa6 libosmesa6:i386
  librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2
  librygel-server-2.6-2 libswresample-dev libswresample3 libswresample3:i386
  tracker
43 upgraded, 11 newly installed, 6 to remove and 1073 not upgraded.
965 not fully installed or removed.
Need to get 0 B/72.1 MB of archives.
After this operation, 665 MB disk space will be freed.
Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Setting up libtinfo6:amd64 (6.3-2ubuntu0.1) ...
Setting up libncursesw6:amd64 (6.3-2ubuntu0.1) ...
Setting up readline-common (8.1.2-1) ...
Setting up libreadline8:amd64 (8.1.2-1) ...
Setting up libpython3.10-stdlib:amd64 (3.10.12-1~22.04.3) ...
Setting up python3.10 (3.10.12-1~22.04.3) ...
Setting up libpython3-stdlib:amd64 (3.10.6-1~22.04) ...
Setting up python3 (3.10.6-1~22.04) ...
running python rtupdate hooks for python3.10...
running python post-rtupdate hooks for python3.10...
Setting up lsb-release (11.1.0ubuntu4) ...
(Reading database ... 307019 files and directories currently installed.)
Preparing to unpack .../00-libgs9_9.55.0~dfsg1-0ubuntu5.6_amd64.deb ...
Unpacking libgs9:amd64 (9.55.0~dfsg1-0ubuntu5.6) over (9.50~dfsg-5ubuntu4.11) ...
Preparing to unpack .../01-libgs9-common_9.55.0~dfsg1-0ubuntu5.6_all.deb ...
Unpacking libgs9-common (9.55.0~dfsg1-0ubuntu5.6) over (9.50~dfsg-5ubuntu4.11) ...
Preparing to unpack .../02-fonts-urw-base35_20200910-1_all.deb ...
Unpacking fonts-urw-base35 (20200910-1) over (20170801.1-3) ...
Preparing to unpack .../03-gedit-common_41.0-3_all.deb ...
Unpacking gedit-common (41.0-3) over (3.36.2-0ubuntu1) ...
Preparing to unpack .../04-libgnome-autoar-0-0_0.4.3-1_amd64.deb ...
Unpacking libgnome-autoar-0-0:amd64 (0.4.3-1) over (0.2.3-2ubuntu0.4) ...
Preparing to unpack .../05-libgl1-mesa-dri_23.0.4-0ubuntu1~22.04.1_amd64.deb ...
De-configuring libgl1-mesa-dri:i386 (21.2.6-0ubuntu0.1~20.04.2), to allow configuration of libgl1-mesa-dri:amd64 (21.2.6-0ubuntu0.1~20.04.2) ...
Unpacking libgl1-mesa-dri:amd64 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../06-libgl1-mesa-dri_23.0.4-0ubuntu1~22.04.1_i386.deb ...
Unpacking libgl1-mesa-dri:i386 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../07-libosmesa6_23.0.4-0ubuntu1~22.04.1_amd64.deb ...
De-configuring libosmesa6:i386 (21.2.6-0ubuntu0.1~20.04.2), to allow configuration of libosmesa6:amd64 (21.2.6-0ubuntu0.1~20.04.2) ...
Unpacking libosmesa6:amd64 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../08-libosmesa6_23.0.4-0ubuntu1~22.04.1_i386.deb ...
Unpacking libosmesa6:i386 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../09-libglx-mesa0_23.0.4-0ubuntu1~22.04.1_amd64.deb ...
De-configuring libglx-mesa0:i386 (21.2.6-0ubuntu0.1~20.04.2), to allow configuration of libglx-mesa0:amd64 (21.2.6-0ubuntu0.1~20.04.2) ...
Unpacking libglx-mesa0:amd64 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../10-libglx-mesa0_23.0.4-0ubuntu1~22.04.1_i386.deb ...
Unpacking libglx-mesa0:i386 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../11-libglapi-mesa_23.0.4-0ubuntu1~22.04.1_i386.deb ...
De-configuring libglapi-mesa:amd64 (21.2.6-0ubuntu0.1~20.04.2), to allow configuration of libglapi-mesa:i386 (21.2.6-0ubuntu0.1~20.04.2) ...
Unpacking libglapi-mesa:i386 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../12-libglapi-mesa_23.0.4-0ubuntu1~22.04.1_amd64.deb ...
Unpacking libglapi-mesa:amd64 (23.0.4-0ubuntu1~22.04.1) over (21.2.6-0ubuntu0.1~20.04.2) ...
Preparing to unpack .../13-libglx0_1.4.0-1_i386.deb ...
De-configuring libglx0:amd64 (1.3.2-1~ubuntu0.20.04.2), to allow configuration of libglx0:i386 (1.3.2-1~ubuntu0.20.04.2) ...
Unpacking libglx0:i386 (1.4.0-1) over (1.3.2-1~ubuntu0.20.04.2) ...
Preparing to unpack .../14-libglx0_1.4.0-1_amd64.deb ...
Unpacking libglx0:amd64 (1.4.0-1) over (1.3.2-1~ubuntu0.20.04.2) ...
Preparing to unpack .../15-libegl1_1.4.0-1_amd64.deb ...
Unpacking libegl1:amd64 (1.4.0-1) over (1.3.2-1~ubuntu0.20.04.2) ...
Preparing to unpack .../16-libglvnd0_1.4.0-1_amd64.deb ...
De-configuring libglvnd0:i386 (1.3.2-1~ubuntu0.20.04.2), to allow configuration of libglvnd0:amd64 (1.3.2-1~ubuntu0.20.04.2) ...
Unpacking libglvnd0:amd64 (1.4.0-1) over (1.3.2-1~ubuntu0.20.04.2) ...
Preparing to unpack .../17-libglvnd0_1.4.0-1_i386.deb ...
Unpacking libglvnd0:i386 (1.4.0-1) over (1.3.2-1~ubuntu0.20.04.2) ...
Preparing to unpack .../18-libnautilus-extension1a_1%3a42.6-0ubuntu1_amd64.deb ...
Unpacking libnautilus-extension1a:amd64 (1:42.6-0ubuntu1) over (1:3.36.3-0ubuntu1.20.04.2) ...
Preparing to unpack .../19-tracker_3.3.0-1_amd64.deb ...
Unpacking tracker (3.3.0-1) over (2.3.6-0ubuntu1) ...
Preparing to unpack .../20-cups-server-common_2.4.1op1-1ubuntu4.7_all.deb ...
Unpacking cups-server-common (2.4.1op1-1ubuntu4.7) over (2.3.1-9ubuntu1.6) ...
Preparing to unpack .../21-libbabl-0.1-0_1%3a0.1.92-1_amd64.deb ...
Unpacking libbabl-0.1-0:amd64 (1:0.1.92-1) over (0.1.74-1) ...
Preparing to unpack .../22-libavcodec58_7%3a4.4.2-0ubuntu0.22.04.1_i386.deb ...
De-configuring libavcodec58:amd64 (7:4.2.7-0ubuntu0.1), to allow configuration of libavcodec58:i386 (7:4.2.7-0ubuntu0.1) ...
Unpacking libavcodec58:i386 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Preparing to unpack .../23-libavcodec58_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libavcodec58:amd64 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Preparing to unpack .../24-libswresample-dev_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libswresample-dev:amd64 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Preparing to unpack .../25-libswresample3_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
De-configuring libswresample3:i386 (7:4.2.7-0ubuntu0.1), to allow configuration of libswresample3:amd64 (7:4.2.7-0ubuntu0.1) ...
Unpacking libswresample3:amd64 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Preparing to unpack .../26-libswresample3_7%3a4.4.2-0ubuntu0.22.04.1_i386.deb ...
Unpacking libswresample3:i386 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
(Reading database ... 307083 files and directories currently installed.)
Removing libopencv-ts-dev:amd64 (4.2.0+dfsg-5) ...
(Reading database ... 307078 files and directories currently installed.)
Preparing to unpack .../libopencv-videoio-dev_4.5.4+dfsg-9ubuntu4_amd64.deb ...
Unpacking libopencv-videoio-dev:amd64 (4.5.4+dfsg-9ubuntu4) over (4.2.0+dfsg-5) ...
Preparing to unpack .../libopencv-imgcodecs-dev_4.5.4+dfsg-9ubuntu4_amd64.deb ...
Unpacking libopencv-imgcodecs-dev:amd64 (4.5.4+dfsg-9ubuntu4) over (4.2.0+dfsg-5) ...
Preparing to unpack .../libopencv-imgproc-dev_4.5.4+dfsg-9ubuntu4_amd64.deb ...
Unpacking libopencv-imgproc-dev:amd64 (4.5.4+dfsg-9ubuntu4) over (4.2.0+dfsg-5) ...
Preparing to unpack .../libopencv-core-dev_4.5.4+dfsg-9ubuntu4_amd64.deb ...
Unpacking libopencv-core-dev:amd64 (4.5.4+dfsg-9ubuntu4) over (4.2.0+dfsg-5) ...
(Reading database ... 307094 files and directories currently installed.)
Removing libavresample-dev:amd64 (7:4.2.7-0ubuntu0.1) ...
(Reading database ... 307085 files and directories currently installed.)
Preparing to unpack .../libavutil-dev_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libavutil-dev:amd64 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
(Reading database ... 307090 files and directories currently installed.)
Removing libavresample4:amd64 (7:4.2.7-0ubuntu0.1) ...
(Reading database ... 307084 files and directories currently installed.)
Preparing to unpack .../0-libavutil56_7%3a4.4.2-0ubuntu0.22.04.1_i386.deb ...
De-configuring libavutil56:amd64 (7:4.2.7-0ubuntu0.1), to allow configuration of libavutil56:i386 (7:4.2.7-0ubuntu0.1) ...
Unpacking libavutil56:i386 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Preparing to unpack .../1-libavutil56_7%3a4.4.2-0ubuntu0.22.04.1_amd64.deb ...
Unpacking libavutil56:amd64 (7:4.4.2-0ubuntu0.22.04.1) over (7:4.2.7-0ubuntu0.1) ...
Selecting previously unselected package libx264-163:i386.
Preparing to unpack .../2-libx264-163_2%3a0.163.3060+git5db6aa6-2build1_i386.deb ...
Unpacking libx264-163:i386 (2:0.163.3060+git5db6aa6-2build1) ...
Selecting previously unselected package libx265-199:i386.
Preparing to unpack .../3-libx265-199_3.5-2_i386.deb ...
Unpacking libx265-199:i386 (3.5-2) ...
Selecting previously unselected package libcodec2-1.0:amd64.
Preparing to unpack .../4-libcodec2-1.0_1.0.1-3_amd64.deb ...
Unpacking libcodec2-1.0:amd64 (1.0.1-3) ...
Selecting previously unselected package libx264-163:amd64.
Preparing to unpack .../5-libx264-163_2%3a0.163.3060+git5db6aa6-2build1_amd64.deb ...
Unpacking libx264-163:amd64 (2:0.163.3060+git5db6aa6-2build1) ...
Selecting previously unselected package libraw20:amd64.
Preparing to unpack .../6-libraw20_0.20.2-2ubuntu2.22.04.1_amd64.deb ...
Unpacking libraw20:amd64 (0.20.2-2ubuntu2.22.04.1) ...
Preparing to unpack .../7-libgegl-common_1%3a0.4.34-1build1_all.deb ...
Unpacking libgegl-common (1:0.4.34-1build1) over (0.4.22-3) ...
Preparing to unpack .../8-libgegl-0.4-0_1%3a0.4.34-1build1_amd64.deb ...
Unpacking libgegl-0.4-0:amd64 (1:0.4.34-1build1) over (0.4.22-3) ...
Preparing to unpack .../9-libdc1394-dev_2.2.6-4_amd64.deb ...
Unpacking libdc1394-dev:amd64 (2.2.6-4) ...
dpkg: error processing archive /tmp/apt-dpkg-install-TjSUtb/9-libdc1394-dev_2.2.6-4_amd64.deb (--unpack):
 trying to overwrite '/usr/include/dc1394/camera.h', which is also in package libdc1394-22-dev:amd64 2.2.5-2.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /tmp/apt-dpkg-install-TjSUtb/9-libdc1394-dev_2.2.6-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Which server are you set to in Software & Updates > "Download from"?

thanks for the reply, apologies for going dark. later that evening while trying to troubleshoot I ended up rebooting and the system wouldn't boot. rather than continue digging deeper into that, I ended up doing a clean install of 17, which has been interesting and am going to post a separate thread

2 Likes