Upgrade tool does not show version 17

I received the mail, that ZorinOS 17 is available now.
Unfortunately, the inplace upgrade tool does not show the option to upgrade to 17.
The only option is the Upgrade to ZorinOS 16.3 Pro.
I tried to apt update and
sudo apt install --reinstall update-manager update-manager-core dbus
But it did not help.

Am I missing something on the way?
I purchsed the Pro version for 17 and would like to update my existing 16.3 core to 17 pro.
The upgrade tool says, that I am on 16.3 Education, but I think, I installed core.
Don't know, if it makes a difference.

Any ideas on that?

You could try another server in software and updates. I suspect the servers are busy since the upgrade announcement. The only difference between education and core is EDU related programs.

It was possible to upgrade from 16 Core to 16 Pro:

I would advise that you contact Team Zorin as purchasing the Pro version entitles you to help from the team using this Contact Form:

1 Like

Thank you for the reply.
I sent a mail to the support team.

Writing to the support turns out as an absolute waste of time.
Standard reply without even reading my mail and asking stuff, that is already mentioned in my request.
I would have been better off getting something else for the money.
I think, I will give Suse tumbleweed a try and will have a look at ZorinOS later.

Okay - update for lost souls like me :wink:
That ZorinOS 17 is not officially released for 16.3 Education

You can get it, if you bought "Pro" (like I did).

Install the latest updates from the Software Updater
Open the Terminal (Ctrl+Alt+T) and enter this command: gsettings set com.zorin.desktop.upgrader show-test-upgrades true
Open the Zorin menu > search & open "Upgrade Zorin OS"
After the Upgrade Zorin OS app finishes checking for upgrades, click the "Upgrade" button beside the "Zorin OS 17 Pro" option.
Follow the on-screen instructions and enter your order details for Zorin OS 17 Pro when prompted.

That update messed up my install. After fiddling around a bit, I managed to get the standard Gnome desktop. So I was able to work again.

Here is, what solved my problem:
What I did:

Edit /etc/apt/sources.list and uncommented eveything except:

deb Index of /ubuntu jammy-backports main restricted universe multiverse
deb-src Index of /ubuntu jammy-backports main restricted universe multiverse

deb Index of /ubuntu jammy partner
deb-src Index of /ubuntu jammy partner

deb Index of /ubuntu jammy main restricted universe multiverse

deb Index of /ubuntu jammy-updates main restricted universe multiverse

deb Index of /ubuntu jammy-security main restricted universe multiverse

Then I ran the usual sudo apt update - upgrade
After that, I dropped the following install line:

sudo apt install ukui-control-center ukui-desktop-environment ukui-desktop-environment-core ukui-desktop-environment-extras ukui-media ukui-media-common ukui-menu ukui-menus ukui-panel ukui-power-manager ukui-screensaver ukui-screensaver ukui-session-manager ukui-settings-daemon ukui-settings-daemon-common ukui-settings-daemon ukui-window-switch -y

After the first boot after that, my keyboard and mouse were frozen, so one reboot in ZorinOS options --> generic and after that, everything worked as expected.
Booted again and back to "normal" ZorinOS.
Now I was able to switch to Zorin-Look (Logon-Screen, click name, click gear-icon on the lower right).
Systemtools - Zorin Appearance works now. Everything seems to be fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.