Upgrader fudged up

So I was upgrading ZorinOS 16.3 to 17 and it failed with a "Unable to install updates" issue. I don't know where to find the full logs. The computer thinks it's running Zorin OS 17. What do I do?

I got a new error:

Upgrade Started


[PREPARING:Validating Upgrade Attempt] Started

[PREPARING:Validating Upgrade Attempt] Completed

[PREPARING:Restarting Apt] Started

[PREPARING:Restarting Apt] Completed

[PREPARING] Completed



[INSTALLING NEW APPS:Flatpak] Completed



[SOFTWARE CHANNELS:Processing Repos] Started

[SOFTWARE CHANNELS:Processing Repos] Completed

[SOFTWARE CHANNELS:Updating Apt Cache] Started

[SOFTWARE CHANNELS:Updating Apt Cache] Completed



[INSTALLING UPGRADES:Apt > Calculating Upgradeable Packages] Started

[INSTALLING UPGRADES:Apt > Calculating Upgradeable Packages] Completed

[INSTALLING UPGRADES:Apt > Committing Upgrades] Started

[INSTALLING UPGRADES:Apt > Committing Upgrades] Fatal Error: { error-not-remove-essential: Package libgcc1 cannot be removed }

[INSTALLING UPGRADES:Apt > Committing Upgrades] Failed


Upgrade Failed

Also zorin appearance won't open anymore

The issue preventing zorin appearance from opening is Settings schema 'org.gnome.shell.extensions.zorin-taskbar' does not contain a key named 'panel-lengths'

Please help it's getting worse: Upgrade Started[PREPARING] Started[PREPARING:Validating Upgrade Attempt] Sta - Pastebin.com

Hi Josh,

May I ask how you initiated the upgrade? AFAIK, the official upgrade mechanism is yet to be released.

This sounds like you ran the Upgrade but only partially upgraded.

As @Ragnir pointed out, the Zorin Upgrader Tool has not yet been officially released In Regards to Use With Zorin OS 17.
It is officially released for use with upgrading Zorin OS 15 to 16.

It is important to await the official release in case all packages are not yet in their proper places. In the meantime, let's see if we can try top help:
Can you try changing your Download From to Main Server in Software & Updates. Once done, in terminal run

sudo apt update

Run the upgrade tool again and see if it can now find the missing packages.

Hmm, in my upgrader app it has an option for Zorin OS 17 which I used.

I ran sudo apt update and it didn't change anything, so I ran sudo apt upgrade which installed a bunch of Zorin OS 17 packages and now the installer goes further but has a bunch of errors shown here: Upgrade Started[PREPARING] Started[PREPARING:Validating Upgrade Attempt] Sta - Pastebin.com

I plan on backing everything up, nuking the install and reinstalling.

1 Like

@Aravisian any progress of zorin upgrader tool for 16 to 17 ? its almost 3 weeks release of zorin 17.

1 Like

Could you show a screenshot of which upgrader software did you use? ZorinOS 16.3 reports nothing out of the ordinary for me; at the moment ZorinOS 17 can only be installed by doing a fresh install (which will wipe your hard drive so make sure to make a backup of any important files).

@dipto We can only guess, it's likely we will receive the news of the direct upgrade tool being released rather than a scheduled released date. Stay tuned or subscribed to the newsletter to know right away when it happens.


I used the Zorin Upgrader app

This one? It reports nothing new to me...

If you are willing to re-install, I think that's the best option. Dealing with dependency conflicts is no fun. Of course, make sure to make a backup copy of any important files first.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.