USB C to 3.5mm Audio Adapter doesn't work

My built in audio input gradually stopped working and I decided to buy this adapter in order to use my speakers and headphones again. But when I plug it to the computer nothing happens, the built in speakers continue playing, the sound doesn't go through the external speakers or headphones connected to the adapter.

I bought the adapter today so I presume it's not damaged or something, I was wondering if fixing the problem is related to changing some complicated audio settings in my system, but I'm not that familiar with Linux yet and I need some help. Thank you!

I use Zorin OS 16.1, Core version, single boot. Here's more info:

1 Like

Can you Please Share me the adapter's amazon :smile:

5 Likes

It's this one.

1 Like

Method 1

If the Headphones are muted
Use the terminal

cat /proc/asound/cards 

take a note of the contents.
then run

alsamixer

Select your correct sound card using F6 and select F5 to see recording controls as well
Move around with left and right arrow keys.
Increase and decrease volume with up and down arrow keys.
Increase and decrease volume for left/right channel individually with "Q", "E", "Z", and "C" keys.
Mute/Unmute with the "M" key. An "MM" means muted, and "OO" means unmuted. Note that a bar can be 100% full but still be muted, so do check for this.
Exit from alsamixer with the Esc key.

Method 2

Connect the adapter and Run the Command

lsusb -d 18d1:5033 -v | grep Class

If not Working
Use the following

sudo insmod sound/core/snd-rawmidi.ko
sudo insmod sound/usb/snd-usbmidi-lib.ko
sudo insmod sound/usb/snd-usb-audio.ko

That's the best I can do in this Case :slightly_frowning_face:

5 Likes

In alsamixer everything is on, no muted channels, still not working.

This is the output from the commands in the second method:
insmod: ERROR: could not load module sound/core/snd-rawmidi.ko: No such file or directory
insmod: ERROR: could not load module sound/usb/snd-usbmidi-lib.ko: No such file or directory
insmod: ERROR: could not load module sound/usb/snd-usb-audio.ko: No such file or directory

Still not working. Thanks anyway, ghostminator.

1 Like

Did you have the adapter plugged in before you booted ZorinOS, or did you boot then plug in the new adapter?
Or have you tried plugging in the adapter whilst ZorinoS is running.

1 Like

This may sound stupid, but have you gone into the settings - sound and selected the other device? If you don't, then it will continue to use your built in speakers.

2 Likes