USB devices are not working

Hello everyone,

today it seems that Zorin OS does not recognize my USB devices (keyboard, mouse) anymore. Yesterday there was an update which may be the cause for this issue.

To check if the devices are broken I started Zorin OS from a USB drive and then Zorin OS was able to recognize other USB devices.

Do you have any advice how I can fix this problem? Of course I could do a fresh installation of Zorin OS but I would like to avoid that. I can't access the PC via SSH because it's not running on that PC (or at least I don't think that there is a way to use SSH if I didn't enable it on that PC).

Thanks in advance!

Have you yet tried rolling back to a previous working kernel to see if that is the cause of the issue?

First, I had to find out how to open the recovery menu to boot with an older kernel and found your Howto. In my case I had to repeatedly press the shift key.

Then I tried to boot from the older kernel (5.15.0-53) but I didn't even get to the lock screen this time.

I also saw this error (despite of the version of the kernel I was using:
uvcvideo 3-b:1.1: Failed to set UVC probe control: -32 (exp. 26)

Is that a builtin or USB Webcam?

You are using Legacy (MBR) boot, then...

From Settings > Universal Access, can you ensure that Slow Keys or Bounce Keys has not been accidentally enabled?

Another thing you might check- the Gnome-Extension used to re-enable Desktop Icons can bug this out in the Gnome Shell. Using Gnome Tweak Tool, you can navigate to the Extensions tab and disable the zorin-desktop-icons extension - reboot and test.
if needed:

sudo apt install gnome-tweaks

It's a USB webcam

I will look for that entry in a few minutes

When plugging out the webcam this error didn't appear anymore.

But I still can't use my keyboard and mouse.

I couldn't find that entry but this is not so important right now :slight_smile:

Without mouse and keyboard this will be difficult :wink: Is it possible to do this in the shell? I just tried to connect via SSH (after I installed it in recovery mode) but it times out (although both PCs are in the same network).

Yes, you can use gsettings command. Try:

gsettings set org.gnome.desktop.background show-desktop-icons false


gnome-extensions list

Find the Desktop Icons extension name as listed, then

gnome-extensions disable (The name you acquired above. Do not use the parentheses)

There is no extension installed

Then I get:

dconf-WARNING **: [...]: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY

Are you logging in on Wayland...? :expressionless:

I don't know. I'm using ZorinOS as it is :slight_smile:

How can I set if I want to log in with X-server or Wayland?

On the login screen, it's the cog in the bottom right.

The solution was to switch to X11.

  1. I opened /etc/gdm3/custom.conf and uncommented WaylandEnable=false
  2. Then I had to install X11 via apt install xorg
  3. Somewhere in between some things got lost as it seems for me because I couldn't open the settings for example. Because of that I had to run apt install gnome-software gnome-control-center

Thanks @Aravisian for helping me (although I don't like your last answer)!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.