USB drive recognition

My Zorin Lite recognizes an inserted USB thumb drive as a “disk”, along with the hard drive and CD/DVD player.

But I don’t see a way to transfer files to or from it. What am I missing?

Open Files (Zorin Menu->Accessories->Files). Scroll down the left pane to Other Locations and click on that. Your USB drive will appear under other mounted disks, just left click on it. I am navigating using Core but you should have a similar path, if not exactly the same.

You can also look in the bottom, right hand corner of your screen and you’ll see a little triangle with a line running under the base. If you click on that, it will list all mounted drives and then you can select any of them that way as well.

Thank you for responding.

Unfortunately, I have neither option on my desktop. The USB drive does not appear in “Files”, and the triangle lists only the Main Drive.

You said you see it on Disks, correct? Click on the USB drive in Disks and in the middle area of the right pane you’ll see a Play button. Click that and your USB is now mounted and will appear in files and under the triangle list.

This is what I see when I open “Disks”.

What type of formatting was done on that Thumb Drive?

All I remember is that it was formatted for the purpose of creating a boot drive for the Zorin distribution when I switched over from Windows 7.

I should also mention that Zorin also does not recognize my Seagate FreeAgent outboard storage drive or another thumb drive that I have available.

Use a USB drive that you’re willing to sacrifice the data on (don’t worry, drive will be fine, only data will be lost). Then click that one single button available and it should give you a Format Partition option. Select that, after formatting, see if the drive is accessible.

The Format Partition option for the USB drive generates the message “Error synchronizing after initial wipe: Timed out waiting for object (udisks-error-quark, 0)”.

Can you try the solution suggested here?

PS - One more thing to note. In Disks, always press the power button (green rectangle around it in pic, below) and wait for the drive to be unmounted before unplugging any USB drive. If you do otherwise, you risk data corruption.


Setting aside the issue of formatting USB thumb drives for the moment, I’d like to focus upon the fact that Zorin does not recognize the existence of my Seagate FreeAgent external hard drive.

I’m aware of a “power-saving” issue with Ubuntu distros that causes the FreeAgent to shut down after a few minutes, along with the workaround. But the Seagate drive doesn’t even appear on my “Disks” list.

As far as I’m aware, Seagate FreeAgent is a USB connected drive. The problem with your system is that none of these USB drives appear as formatted. That is why the solution in is still the next step.

Unfortunately, we’re getting into an area that’s beyond my knowledge and capabilities.

I installed GParted, and for every USB-connected device (two thumb drives and the Seagate FreeAgent) the screen looks exactly the same. So I can’t “choose the right drive” as per the instructions.

Can you type lsblk into the terminal (ctrl+alt+t) and post the results?

sda5 is your Zorin root. The ntfs (sda1-3) are your Windows partitions. But I’d like to see what lsblk shows with your USBs connected.

Screenshot from 2020-12-19 18-04-29

You have no home or swap partitions. For example, see mine:
sda 8:0 0 465.8G 0 disk
├─sda1 8:1 0 47.7G 0 part /
├─sda2 8:2 0 1K 0 part
├─sda5 8:5 0 7.7G 0 part [SWAP]
└─sda6 8:6 0 410.5G 0 part /home
sr0 11:0 1 1024M 0 rom

Can you elaborate on the steps on how you installed Zorin?

I no longer remember the online source of the installation instructions, but I downloaded Zorin to a properly formatted thumb drive and booted it from there. I was seeking a viable Linux alternative to my Windows 7 Professional OS. The switchover was some time ago, and Zorin has functioned without issues since then.

Well, a minimum root partition is technically sufficient to run Linux, so as long as it runs fine, no worries.

Back to Gparted: click the button which I have drawn a green rectangle around in the attached picture. That dropdown menu should allow you to select your external drives and then you can proceed with the original troubleshooting.

Unfortunately, it does nothing and offers no dropdown menu.