USB Errors on startup and network issues during usage when using a Dell D3100 Dock

So, the only things that were plugged into the Dell D3100:

  • An ethernet cable

  • a 64 GB USB stick (for backing up my browser bookmarks)

an Atolla USB 3.0 Hub (which shows as a Genesys Logic Inc. hub in the CLI via lsusb ):

The Atolla hub has a Micro USB power supply attached. plugged into this hub are a webcam, a microphone (Blue Snowball), and an external USB drive (8TB Seagate). The last port is left open to plug a phone into for charging.

The Seagate drive has its own power supply. As the other devices may draw more power than the D3100 may provide across its port(s), the Atolla can be powered by a Micro-USB power adapter. I have such a power adapter plugged into it.

BTW - the D3100 also has its own power supply.

Per the links you provided, I did indeed disconnect everything, and also disconnected the power supply connected to the D3100. Additionally, I unplugged the D3100's power supply from its outlet, and left it that way for about 10 minutes.

Plugged everything back in, and restarted. Issue persisted.

Then, to test - disconnected the Atolla.

shut down, started back up.

NO ERRORS on startup.

Everything worked - no lag with the keyboard and mouse.

Unplugged the power supply to the Atolla, and reconnected it. Issues were back.

Disconnected all peripherals from the Atolla (they were all turned off prior to this, but I figured let's be thorough), and reconnected it back to the D3100. Previously described issues were present.

Left the Atolla disconnected, then powered on the system - no issues. Plugged in the Atolla while the system was up and running - could use the attached peripherals.

So, as a temporary workaround - I figured I'd leave the Atolla disconnected.

Then, a new issue was introduced. It is documented here:

Now when the computer exits from suspend - I now consistently lose my network connection via ethernet and access to my external speakers - both plugged into the D3100. Interestingly, the USB stick which is attached to the D3100 shows up just fine and can be accessed.

In some ways, this is now worse. That said - while they may certainly be related, I consider the suspend a separate issue, hence creating a different thread to troubleshoot it.

That's the story as of today...

Update - I was able to successfully prevent the computer from suspending while preserving other options I feel are necessary.

Startup and login now function normally, and all usb devices currently attached function with no issue.

This is when the Atolla/Genesys Logic, Inc. Hub is disconnected.

The issues are re-introduced when the hub is attached - even if nothing is connected to it, including a power supply for it.

As a work around, I can leave the hub disconnected until I need access to the devices normally connected to it.

That said - this is not an ideal solution ("Doctor, it hurts when I do xyz." "Then, don't do xyz."), especially when there were no issues with the hub connected in this configuration using Zorin 15.3.

Well said. Drivers that are compatible are necessary for the hardware to work. What is uncertain, in my mind at least, is whether these drivers are available for GnuLniux or not.
I have tried some searching, but have also been overwhelmed with other tasks and have had less time available.

Using a work-around as a bandaid until a solution is still better than nothing at all.

I would also consider your laptop battery. I had some Weird BSOD's on my Win laptop. Whilst battery worked OK and PC also connected to mains. But new battery has improved things.
Laptop battery acts as a power regulator, so if its outpout is compromised then internal voltages may also be compromised, including USB functionality.

mainadmin@Office:~$ upower -i /org/freedesktop/UPower/devices/battery_BAT0

native-path: BAT0
vendor: ASUSTeK
model: ASUS Battery
power supply: yes
updated: Wed 24 Jan 2024 04:31:15 PM MST (116 seconds ago)
has history: yes
has statistics: yes
present: yes
rechargeable: yes
state: fully-charged
warning-level: none
energy: 29.209 Wh
energy-empty: 0 Wh
energy-full: 29.209 Wh
energy-full-design: 37.13 Wh
energy-rate: 0 W
voltage: 7.85 V
charge-cycles: 7
percentage: 100%
capacity: 78.6668%
technology: lithium-ion
icon-name: 'battery-full-charged-symbolic'

mainadmin@Office:~$ acpi -V
Battery 0: Not charging, 100%
Battery 0: design capacity 4729 mAh, last full capacity 3720 mAh = 78%
Adapter 0: on-line
Thermal 0: ok, 43.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 103.0 degrees C
Cooling 0: Processor 0 of 0
Cooling 1: iwlwifi_1 no state information available
Cooling 2: TCC Offset 5 of 63
Cooling 3: Processor 0 of 0
Cooling 4: INT3400 Thermal no state information available
Cooling 5: Processor 0 of 0
Cooling 6: B0D4 no state information available
Cooling 7: intel_powerclamp no state information available
Cooling 8: x86_pkg_temp no state information available
Cooling 9: Processor 0 of 0
Cooling 10: SEN1 no state information available

I don't know how accurate that info is. But says battery design capacity is 4729 mAh but you only got 3720 mAh = 78% when 100% charged. Have you done some battery calibration cycles e.g. full drain then full charge and repeat?
I would think that offers some evidence that a new battery may be a good investment, especially if you are attaching several devices to USB, whether they are self powered or not.
If a new battery does not help, then nothing is lost as you can keep it as a spare. Just keep it charged at about 50-60% when removed.

1 Like

Issue still persists.

Are you reporting this after having taken action such as calibration or battery replacement?

Battery has been calibrated:

As well as there have been several software updates since this issue was initially reported, and none of them have resolved the issue.

Work around which has been employed - I stopped using the hub. This is not desirable, but gets the job done.

A potential alternate work around - I could use another distro which does not exhibit the issue, but I do prefer to use Zorin. It would be nice to see this issue resolved.

1 Like

I agree. This does imply that the issue lies with the HUB and some Zorin system issue.

Can I ask which distro has this corrected? That may help to look for a solution within the open source community.

Haven't attempted this. As I wrote, I could use another distro which does not exhibit the issue. Haven't tried, yet.

My next attempt will be with Debian - it checks most of the boxes I need, so I can give that a go and see if the most current version resolves the issue.

1 Like