USB Errors on startup and network issues during usage when using a Dell D3100 Dock

New erase and install of Zorin 17 this week. [For the most part, I like it a lot. Kudos!]

I am using an Asus VivoBook X512JA_R564JA with an Intel® Core™ i3-1005G1 CPU @ 1.20GHz × 4, Mesa Intel® UHD Graphics (ICL GT1), 128.0 GB SSD, 20 GB of RAM.

Here is what I have currently attached:

Bus 002 Device 006: ID 05e3:0626 Genesys Logic, Inc. USB3.1 Hub
Bus 002 Device 005: ID 17e9:436e DisplayLink Dell D3100 Docking Station
Bus 002 Device 004: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 003: ID 17e9:436e DisplayLink Dell D3100 Docking Station
Bus 002 Device 002: ID 2109:0812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 008: ID 13d3:56dd IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 005: ID 046d:c00e Logitech, Inc. M-BJ58/M-BJ69 Optical Wheel Mouse
Bus 001 Device 003: ID 04d9:a0cd Holtek Semiconductor, Inc. USB Keyboard
Bus 001 Device 011: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 006: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 007: ID ffff:5678 USB Disk 2.0
Bus 001 Device 004: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 002: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

The issue - I may lose network connectivity over my ethernet connection from my Dell D3100 dock, or access to my USB devices (hubs, usb sticks, keyboard, mouse, etc. The keyboard and mouse are odd, as they are plugged directly into the computer - not through an external hub). Random.

During startup, I often get the following errors:

This makes for a very long time in acquiring a desktop.

Once I achieve a desktop, some of my USB devices may work, others may not. Again, Random.

Also, if the computer suspends, after bringing out of suspension - there are many instances of the network connection simply disappearing - I open up Network Manager, and ethernet doesn't even show up.

On the occasions where the computer starts up and DOES NOT SHOW the above screenshot error messages, either at a login window or at a desktop if I enable automatic login - the keyboard and mouse are unavailable for about a minute.

After that, they become available and I can either log in, or if I am at a desktop, use the computer.

If I do not have the Dell D3100 attached, the above-described issues are resolved.

I recently installed Zorin 17 after running Zorin 15.3. These issues were not present in Zorin 15.3, and continue to not be present (I cloned my system off onto a USB stick, and when I boot from that everything works fine with the Dell D3100 attached) if I boot back into it.

The only change has been the OS.

For troubleshooting, I swapped the USB cable on the Dell D3100 - issue persists.

My firmware on the Asus was older (303) and there was an upgrade available (310). I upgraded my firmware successfully - issue persists.

I have not installed the driver from Dell for the dock. Reason, per the Dell website:

"The driver enables video support for products using DisplayLink USB 3.0 technology. Standard native Ubuntu drivers provide support for DisplayLink audio and Ethernet interfaces."

Thanks in advance for attention to this topic's issue; I look forward to a return to the stability I enjoyed in Zorin 15.

I'm getting something similar in Zorin OS 16.3 Core... there's something screwy with the USB subsystem... my drives will randomly drop out after running for a few days, I unplug them and plug them back in, and sometimes they come back, sometimes not. A reboot solves the problem, but I've currently got a long-running process I'd like to complete (a circuit simulator) that will take a couple weeks, and thus far I've not been able to run it that long.

I think it's a resource leak in the USB subsystem.

I have another laptop (A Dell Inspiron 3153) running Zorin 16.3. Normally, nothing is physically connected to it except for a power cable and headphones. with the occasional USB thumb drive attached for file transfers (so, no Dell dock).

Per Mr. Magoo's response, I tested this Dell D3100 Dock USB setup I have on the Dell running Zorin 16.3 and I can confirm the issue is present there as well.

Issue is NOT present in Zorin 15.3.

I do not have any monitors connected to the Dell D3100, so I do not need the DisplayLink driver from Dell. That said - just for the purpose of testing, I installed the driver on the Asus running Zorin 17:

Not only did the drive not resolve the issue - it made it worse.

On restart - the computer was not responsive, no network connection at all. I walked away, came back after 2 minutes - network connection was present and the computer was now responsive.

Prior to the installation of this driver, the behavior was often: show the errors on startup>achieve a login window or desktop>computer was responsive, and either I would log in, or begin using the computer

Dell driver is getting uninstalled now.

That said - issue is still persisting.

Is this a Thunderbolt dock?



Dell D3100:

1 Like

Ah, this explains why you tried the DisplayLink drivers.

(BTW, the SGX disabled by BIOS is just a BIOS setting that you can enable or disable at will. It is Intels "Secure Guard Extension".)

Much as I would love to blame Dell... I think this may be a bug with Wayland and GDM3.

You might try switching to the Zorin Desktop on X and testing the drivers on the xorg X Windowing System (Standard) before removing the DisplayLink driver.

Have you tried rolling back the kernel (If not, this is easy to do so please ask if you need a hand)?

I have not tried this.

Please explain exactly how you would like me to do this. I will do so per your instructions and report back my findings.

Additional info:

Earlier, USB and ethernet were functioning. I left the unit on and went to do some other tasks. Came back, the unit had gone into suspend.

Brought the unit out of suspend, and logged in. USB devices were showing as connected, but ethernet network connection was non-existent.

CLI command lsusb showed the Dell D3100 as attached.

Did a restart - no error messages on restart. Got to a desktop (set to auto login), mouse and keyboard not available for about a minute, then were responsive. No ethernet connection.

Set timer - came back 24 minutes later - no ethernet connection.

Shut down.

Booted up. No error messages on startup. Got to a desktop (set to auto login), mouse and keyboard not available for about a minute, then were responsive. No ethernet connection. About 3 minutes later, started a ping via CLI to my ISP - packets going through just fine. Checked network manager - ethernet connection showing present.

Restarted into GRUB:

Selected to start up with Linux 6.2.0-39 generic (previously, had tried with 6.5.0-14-generic Recovery Mode; issue persisted in that test).

Computer restarted - no error messages on restart. Got to a desktop (set to auto login), mouse and keyboard not available for about a minute, then were responsive. Ethernet connection available; able to ping ISP.

Left the unit on and went to do some other tasks. Came back, the unit had gone into suspend.

Brought the unit out of suspend, and logged in - no lag with connecting to keyboard or mouse for the login procedure. On desktop, USB devices were showing as connected, ethernet network connection was available and functional.

Shut down.

Started up, selected via shift to go into GRUB menu.

Selected to start up with Linux 6.2.0-39 generic as previously attempted.

Computer started - no error messages on startup.

Got to a desktop (set to auto login), mouse and keyboard immediately available. Ethernet connection available; able to ping ISP.

Left the unit on and went to do some other tasks. Came back, the unit had gone into suspend.

Brought the unit out of suspend, and logged in - no lag with connecting to keyboard or mouse for the login procedure. On desktop, USB devices were showing as connected, ethernet network connection was available and functional.

So, temporary rollback test from Linux 6.5.0-14 generic to Linux 6.2.0-39 generic shows a major improvement.

The USB lag for the keyboard and mouse on initial startup is annoying, but I can do other tasks during this startup process and then start using the machine when it is fully functional.

That said - it would be excellent to address this, and as it still appears to be the USB issue as related to this thread - I'd like to leave this open until this issue is resolved completely.

The resolution to the ethernet issue is extremely important, and as a workaround, I will roll back to the earlier kernel so I have this functionality. Again - I'd like to leave this thread open until this issue is resolved completely for kernel Linux 6.5.0-14 generic (or is superseded by a newer kernel which does not exhibit this issue).

At your convenience, please let me know the preferred method for rolling back the kernel in Zorin 17, and I will do so as a temporary workaround until this issue is completely resolved.

Thank you.

Sorry for the delay. I went offline for a bit.
Please see this guide here to set your default kernel to the working kernel:

Newer kernels can mean new bugs or new regressions.
The method above will default boot you to the working kernel, but unlike placing an apt mark hold, it will not prevent you from upgrading the kernel or other packages.
So you can safely run all upgrades.
Kernel regressions or bug fixes must be awaited for the next release of the kernel.

This is why it is important to remember that stability is the prime focus, not the latest. Many members join the forum and ask for the latest, latest, latest only because it is new and shiny.
There can be benefits to newer packages or kernels, of course. Including the addition of drivers for new hardware or due to patches and bugfixes. these must be carefully weighed, not assumed. Members with new hardware can get assistance here in installing a kernel that they need based on their hardware, not based on a version number.

To this end; I would consider that kernel issue "solved" simply because it is the only solution: Use the working kernel.

Thank you for the kernel rollback guide.

I concur - stability is of paramount importance. One of the reasons I switched to Zorin several years ago - I find it to be remarkably stable, and it satisfies my needs for an operating system.

I'm uninterested in "new and shiny;" I'm interested in, "will it work with my setups."

With that said - some of the software I use no longer functions in Zorin 15.x. I installed 16.x on one of my computers recently, and found it somewhat lacking overall. I had to do quite a bit of tweaking to make it work almost as well as 15.x, and there are still issues with it as far as I am concerned.

When 17 became publicly available, I tested it and found it to be far superior to 16.x. As it was available (and not in beta) I figured it would be well tested and acceptable to use. I understand and appreciate technical issues; that said, I figured things like ethernet connectivity and USB support would be pretty stable. Obviously not; lesson learned.

I disagree; while the option to roll back to an earlier version of the kernel is a major improvement over the most egregious aspects of this situation, this still does not solve all of the USB issues - delay in the use of the keyboard and mouse - an issue which was not present in Zorin 15.x.

Again, thank you for your assistance up to this point.

Can you please post a reminder on each remaining USB issue? I clearly missed something. My eyes were probably drawn to the successes...

I will certainly do so after some more testing tomorrow.

For now, after following your instructions to the letter from "[HOW TO] set an older kernel to default boot," I shut down, started back up the computer in question, launched terminal, and ran uname -r to display the kernel version. Version shown is 6.5.0-14-generic, and not the desired version - 6.2.0-39-generic.

Screenshot from 2024-01-18 23-49-15

Any ideas on why this might be would be greatly appreciated. Thank you.

1 Like

You must be booted into the desired kernel, first.
Reboot, use the Advanced Options For Zorin to select the 6.2.0-39 kernel and on ce booted, ensure you are on that kernel

uname -r

Then run

sudo update-grub

Interesting - I did that, but as indicated, the kernel didn't change.

Tried again per your instruction and it appears the kernel is now the selected one - 6.2.0-39-generic.

Unfortunately - this does not resolve the issues I've been experiencing.

Left the computer suspended overnight. Unsuspending it, the primary mouse button was non-functional. Couldn't select to restart, power off, or anything else. I had screen sharing enabled, so connected to the computer from another computer and attempted to control it - the mouse button issue was present even across screen sharing.

Fortunately, the keyboard on the computer in question still worked, so I was able to launch terminal and shut down from there.

After starting back up - still getting USB errors on startup:

After achieving a desktop, everything functioned as expected.

Once the computer suspends, or suspends and is then taken off of suspension - this is where the issues seem to be the worst. Today, it once again lost network connectivity over ethernet, and something new - no audio. I have my speakers plugged into the audio port on the Dell D3100 docking station. The audio quit when the computer suspended - it was playing music.

Interestingly, I have the computer to suspend only when on battery power, and for the screen to blank after 15 minutes:

It is not only plugged into electrical power - it is plugged into a UPS. It should never go on battery power, and thus - should never automatically suspend. The only thing that should happen is the screen (I have an external monitor attached, plugged directly into the HDMI port on the computer) should go black after 15 minutes.

For further testing, I've turned off automatic suspend. I don't mind if the computer stays on - I do want the monitor to go off after a period of inactivity, however.

I'll keep an eye on it over the next couple of days, but sadly - it appears rolling back the kernel did not resolve the issues at hand.

Was there anything else that resulted in this post that may have contributed to it appearing successful?

I hesitate to think a later kernel is needed, due to the D3100 gaining support pretty early on.

Check your BIOS / UEFI... I had a computer once that had a 'handoff' type thing where the options were that the BIOS continue controlling USB devices after initial startup, or control was handed off to the OS during boot.

Likely you don't have it, but my computer was a Dell, so...

I wish my BIOS/UEFI was that advanced. The only mention of USB is in the Advanced>USB Configuration>USB Mass Storage Driver Support [Enabled], and in Security>I/O Interface Security>USB Interface Security - all items set as unlocked.


At this juncture - I have no idea. The issues appear to be random. For instance - I restarted just now into BIOS to get the screenshots I provided. Restarted from that, and the error messages I've posted earlier did not show up. However, the mouse was unresponsive for about a minute on the desktop, then became available. About 30 seconds after that, I achieved network access via ethernet.

The only constants appear to be:

  • related to the USB bus

  • related to the Dell D3100 Dock

  • issues are present on power on, restart, or related to suspend (either entering into, being in, or coming out of suspend)

Since previously mentioned, I've disabled suspend and set the monitor to blank after 15 minutes. I'll leave it that way overnight and see what occurs tomorrow morning.

Looking at this Aptio BIOS screen. The status of USB is ambiguous "UNLOCK". Does that really mean USB is unlocked or asking to click to unlock. What are the options when you click that item. i.e. is the alternative to "UNLOCK" actually "LOCKED"?

Out of curiosity I have been doing some websearches re "Dell D3100 Dock Ubuntu". There are a few cases of displaylink problems with external monitors on D3100, resolved by updating displaylink driver. I assume you have been doing similar web searches as well.

1 Like

Indeed, "UNLOCK" indicates that USB is currently unlocked. The other alternative is indeed, "LOCKED."

I am quite familiar with these issues. When the D3100 worked (for video) it worked really well. At one point in time, I was running dual monitors via the D3100; then, after various updates, I had loads of issues with it. Eventually, I ditched the dual monitors and now use a single large monitor plugged directly into the HDMI port of the computer in question, bypassing the video capabilities of the D3100.

Essentially, I'm not using the D3100 to its fullest effect. I use it as a USB hub and for the ethernet connection. For a lot of complicated reasons, I need to use ethernet in my office, and the computer I'm currently using doesn't have an ethernet port on it. So, it's Ethernet Connection>D3100>Computer's USB 3.0 port that gives me my network connection. Up until using Zorin 17, this all just worked and wasn't an issue.

Speaking of which...

Changed some of the settings and have been running with them for the past 24 hours.

Settings>Power>Screen Blank - 15 minutes

Settings>Power>Automatic Power Saver - OFF

Settings>Power>Automatic Suspend - OFF

Settings>Privacy>Screen>Blank Screen Display - 15 minutes

Settings>Privacy>Screen>Automatic Screen Lock - ON

Settings>Privacy>Screen>Automatic Screen Lock Display - 3 Minutes

Settings>Privacy>Screen>Lock Screen On Suspend - OFF

In theory, The unit stays on, and after a period of time, the external monitor shuts down.

[I say in theory, because the power indicator on the computer shows the computer is in sleep mode after a period of inactivity - which is actually desired behavior.]

Past 24 hours - power on the external monitor, input some keystrokes on the external USB keyboard, the computer has come out of suspend (if it ever actually was truly suspended), and the computer achieves a desktop with no issue - all devices and network connection intact.

So, that's a step in the right direction. Very positive.

Still - when booting up - takes a LONG time to boot as it still shows the error codes indicated in the previous screenshots.

On the occasion it does NOT show these error codes, unit quickly achieves a desktop but the keyboard and mouse are unavailable for about a minute, and the network connection comes online about 30 seconds after the keyboard and mouse have started functioning.

This is rolled back to the older kernel as previously mentioned (6.2.0-39-generic).

That is the current state of affairs.

I did a websearch re those errors. Most refer to timeout, which maybe due to a USB power issue, i.e. USB device/hub taking too much power from USB port. Or maybe you have other USB devices attached to other USB ports that are strain on +5V motherboard supply?

Maybe some comments in these links may help resolve your Dell hub errors.

Some comments suggest success from complete shut down and power off the computer and the hub for some minutes, then power on and reboot.

EDIT: Another thought. Is your laptop battery fairly new and performing well. This may be an issue affecting +5V supply, even when laptop is plugged in to mains power source.