USB ethernet not recognized after reboot

Hi everyone,

I recently purchased a brand-new laptop together with a USB-C IcyBox docking station with ethernet. After reboot, the IcyBox's USB ethernet is not recognized until I unplug the USB-C cable and plug it back in. As this is quite frustrating, I also tried other docking stations meanwhile, unfortunately with the same result. So I suspect it might be an OS issue.

I use Zorin OS 17.1 Core and already tried the command mentioned here right after reboot, while the ethernet adapter was still unrecognized: Strange issue with USB-C Ethernet cable - #9 by BrewCoffeeAddict

Unfortunately, also with no luck - I still need to unplug the USB-C cable after every reboot.

Here are the details of the USB ethernet adapter in question (taken from the command stated earlier):

  *-network
       Beschreibung: Ethernet interface
       Physische ID: d
       Bus-Informationen: usb@3:6.2.3
       Logischer Name: enx34298f734cbe
       Seriennummer: 34:29:8f:73:4c:be
       Größe: 1Gbit/s
       Kapazität: 1Gbit/s
       Fähigkeiten: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       Konfiguration: autonegotiation=on broadcast=yes driver=r8152 driverversion=v1.12.13 duplex=full firmware=rtl8153a-4 v2 02/07/20 ip=192.168.178.117 link=yes multicast=yes port=MII speed=1Gbit/s

Any help is greatly appreciated. Thank you in advance.

Eric

Did You looked if there are any Drivers in the Additional Driver Tab in Software & Updates to install?

Yepp, shows nothing unfortunately.

Hmm ... is on the Manufactorer's Website not any Advice for Linux Usage or maybe a Driver that is needed?

I don't think it's a driver issue, because the ethernet works after I unplug it and plug it back in. It's just that it doesn't get recognized after a reboot. So I thought I might just be missing some USB "wake-up" config on OS level or something.